Bigtop
  1. Bigtop
  2. BIGTOP-177

Remove or fix versioned dependencies between packages of Bigtop

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: 0.2.0
    • Fix Version/s: None
    • Component/s: General
    • Labels:
      None

      Description

      Some packages have inter-dependencies. For instance hbase depends on hadoop.
      But we don't have a consistent versioned dependencies. In the exemple above, the RPMs depends on specific versions of hadoop, whereas the debs don't.

      So we either need to get them consistent or to remove the versions.

      I am personally in favor of removing them, since each bigtop version is a coherent stack and I don't want to support mixed versions of Bigtop

        Activity

        Hide
        Peter Linnell added a comment - - edited

        For Bigtop, I totally agree. No need for versioning within the packages. Also, as a policy we should disclaim any support for use of mixed Bigtop releases.

        Show
        Peter Linnell added a comment - - edited For Bigtop, I totally agree. No need for versioning within the packages. Also, as a policy we should disclaim any support for use of mixed Bigtop releases.

          People

          • Assignee:
            Unassigned
            Reporter:
            Bruno Mahé
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:

              Development