Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-1654

change some hadoop puppet variables from local to node scope

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 0.8.0
    • Fix Version/s: 1.0.0
    • Component/s: deployment, hadoop
    • Labels:

      Description

      the purpose of this change is to refactor certain puppet variables in cluster.pp and init.pp scripts. Precisely, I would like to change the configurable parameters like $ha and $auth from "local" to "node" scope. I believe, there is no need to pass in these variables to every module/class as these parameters doesn't change once set. With puppet 3 (static scoping) , this change is mandatory as I currently see these variables ($ha, $auth) referenced in multiple places assuming that it is defined in some outer scope. This will not work with puppet 3.

      More details of static scoping: https://docs.puppetlabs.com/puppet/latest/reference/lang_scope.html#static-scope

        Activity

        vishnu vishnu gajendran added a comment -

        Hi Evans, thanks for pointing me to the patch. I believe bigtop-1634 will solve the issue I mentioned.

        evans_ye Evans Ye added a comment -

        hi vishnu gajendran just one comment. Please based on BIGTOP-1634 to develop your patch since we're going to get it in shortly, thanks!


          People

          • Assignee:
            Unassigned
            Reporter:
            vishnu vishnu gajendran
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development