Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 1.0.0
    • Component/s: tests
    • Labels:
      None

      Description

      [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.1:compile (default-compile) on project mahout-smoke: Compilation failure: Compilation failure:
      [ERROR] /Users/sananthaleggat/Downloads/real-bigtop/bigtop-tests/test-artifacts/mahout/src/main/groovy/org/apache/bigtop/itest/mahout/smoke/TestMahoutExamples.groovy:[74,1] 1. ERROR in /Users/sananthaleggat/Downloads/real-bigtop/bigtop-tests/test-artifacts/mahout/src/main/groovy/org/apache/bigtop/itest/mahout/smoke/TestMahoutExamples.groovy (at line 74)
      [ERROR] f_name,loc ->
      [ERROR] ^
      [ERROR] Groovy:unexpected token: f_name @ line 74, column 13.
      [ERROR] 
      [ERROR] /Users/sananthaleggat/Downloads/real-bigtop/bigtop-tests/test-artifacts/mahout/src/main/groovy/org/apache/bigtop/itest/mahout/smoke/TestMahoutExamples.groovy:[75,1] 2. ERROR in /Users/sananthaleggat/Downloads/real-bigtop/bigtop-tests/test-artifacts/mahout/src/main/groovy/org/apache/bigtop/itest/mahout/smoke/TestMahoutExamples.groovy (at line 75)
      [ERROR] sh.exec("if [ ! -f ${download_dir}/${f_name} ]; then " +
      [ERROR] ^
      [ERROR] Groovy:unexpected token: sh @ line 75, column 13.
      [ERROR] 
      [ERROR] /Users/sananthaleggat/Downloads/real-bigtop/bigtop-tests/test-artifacts/mahout/src/main/groovy/org/apache/bigtop/itest/mahout/smoke/TestMahoutExamples.groovy:[80,1] 3. ERROR in /Users/sananthaleggat/Downloads/real-bigtop/bigtop-tests/test-artifacts/mahout/src/main/groovy/org/apache/bigtop/itest/mahout/smoke/TestMahoutExamples.groovy (at line 80)
      [ERROR] assertTrue("file "+ f_name + " at  "+loc + " len=" + file.length() + " is > 5k bytes", file.length() > 5000 );
      [ERROR] ^
      [ERROR] Groovy:unexpected token: assertTrue @ line 80, column 13.
      [ERROR] 
      [ERROR] /Users/sananthaleggat/Downloads/real-bigtop/bigtop-tests/test-artifacts/mahout/src/main/groovy/org/apache/bigtop/itest/mahout/smoke/TestMahoutExamples.groovy:[83,1] 4. ERROR in /Users/sananthaleggat/Downloads/real-bigtop/bigtop-tests/test-artifacts/mahout/src/main/groovy/org/apache/bigtop/itest/mahout/smoke/TestMahoutExamples.groovy (at line 83)
      [ERROR] }
      [ERROR] ^
      [ERROR] Groovy:unexpected token: } @ line 83, column 5.
      [ERROR] 
      [ERROR] Found 4 errors and 0 warnings.

      It's caused by commit 3b13a811a8c6ad568a6a3a7b586be9f2fdf4e810 of BIGTOP-1287.

        Issue Links

          Activity

          cos Konstantin Boudnik added a comment -

          Shall the culprit commit be just reverted?

          jayunit100 jay vyas added a comment -

          I'll fix it tonite this should be an easy fix.
          That was an old untested patch we pushed in but necessary...

          dasha.boudnik Dasha Boudnik added a comment -

          I noticed it totally accidentally, wasn't even doing what I meant to be doing thanks!

          jayunit100 jay vyas added a comment -

          Dasha Boudnik thanks for catching this ! that patch had some ugly characters in it . fixed here. let me kno if its good and i can commit !

          jayunit100 jay vyas added a comment -

          attached patch

          dasha.boudnik Dasha Boudnik added a comment -

          Yup, beautiful. Only it's BIGTOP-1611, not BIGTOP-1661, but the patch itself is good to go

          evans_ye Evans Ye added a comment -

          +1
          The fix is is straightforward.

          jayunit100 jay vyas added a comment -

          evans if your free now, can you commit this guy ? I dont have my apache creds w/ me at the moment.

          cos Konstantin Boudnik added a comment -

          Committed. Thanks Jay!

          evans_ye Evans Ye added a comment -

          Sorry the time difference causing me miss the catch


            People

            • Assignee:
              jayunit100 jay vyas
              Reporter:
              dasha.boudnik Dasha Boudnik
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development