Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-1603

Rename docker-puppet and vagrant-puppet to better indicate its function and difference

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 1.0.0
    • Component/s: deployment
    • Labels:
      None

      Description

      Since we're close to the official release which brings the docker provisioner up to the surface. It'd be better to have component names reflect its function naively. (Sorry for the bad naming at the very beginning...). This is also a recall of jay vyas's comment in BIGTOP-1578, and I'm with him. The proposed change:

      docker-puppet --> vagrant-puppet-docker 
      vagrant-puppet --> vagrant-puppet-vm
      

        Attachments

        1. BIGTOP-1603.1.patch
          56 kB
          Evans Ye
        2. BIGTOP-1603.2.patch
          56 kB
          Evans Ye

          Activity

            People

            • Assignee:
              evans_ye Evans Ye
              Reporter:
              evans_ye Evans Ye
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: