Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-1592

Integration test IntegrationTestClusterFailures is failing

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 1.0.0
    • Component/s: tests
    • Labels:
      None
    1. BIGTOP-1592.patch
      4 kB
      Dasha Boudnik

      Issue Links

        Activity

        jayunit100 jay vyas added a comment - - edited

        I would suggest that this is a duplicate of BIGTOP-1528 ... The turning on/off of failure tests is something that is a configuration parameter we can easily add to our existing vagrant based testing i.e. we should be able to go to bigtop-deploy/vm/vagrant-puppet/ , and run vagrant up after editing the vagrantconfig.yaml to have a failure properties on/off feature.

        that will drive adoption of this feature by giving us a live, reproducible demonstration around it which runs in a safe environment

        jayunit100 jay vyas added a comment - - edited

        marking as duplicate, unless im missing something .....

        • let me know your thoughts once you get a chance to think about this Dasha Boudnik !
        • i could be misinterpretting the jira
        • also,even if this isn't a duplicate, id still suggest BIGTOP-1528 might still be considered as a blocker for this - b/c maybe we would want to have failure tests, which are so hard to run and evaluate, as part of our automated tests before adding new features to them . otherwise there is almost 0% chance that anyone will really be able to meaningfully evaluate failure tests as a feature, given the complexity of running such a thing on real hardware
        dasha.boudnik Dasha Boudnik added a comment -

        jay vyas, what I mean is that there are genuine test failures when running these tests. I'll post the description in a minute, but this doesn't duplicate BIGTOP-1528 – totally different deal. Thanks!

        jayunit100 jay vyas added a comment -

        Dasha Boudnik okay, will wait for description. thanks !

        dasha.boudnik Dasha Boudnik added a comment -

        Test was failing because class properties weren't initialized. Fixed.

        cos Konstantin Boudnik added a comment -

        The tests that were failing for me with "null" test host are now passing just fine with mvn verify command.
        +1 on the patch. I will commit it in a bit.

        cos Konstantin Boudnik added a comment -

        Committed and pushed. Thanks Dasha!


          People

          • Assignee:
            dasha.boudnik Dasha Boudnik
            Reporter:
            dasha.boudnik Dasha Boudnik
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development