Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 1.0.0
    • Component/s: tests
    • Labels:
      None
    • Environment:

      JDK7

      Description

      Caused by: Assertion failed: 
      
      assert e.getMessage().startsWith('Could not open')
             | |            |
             | |            false
             | /usr/java/latest/lib/nofilelikethat.jar (No such file or directory)
             java.io.FileNotFoundException: /usr/java/latest/lib/nofilelikethat.jar (No such file or directory)
      1. BIGTOP-1591.patch
        0.8 kB
        Dasha Boudnik

        Activity

        cos Konstantin Boudnik added a comment -

        Committed and pushed. Thanks Dasha!

        cos Konstantin Boudnik added a comment -

        +1 - test if passing now under JDK6 and JDK7

        cos Konstantin Boudnik added a comment -

        I've just checked and the test is definitely fails on JDK7 and works on JDK6: the exception messaging got changed in the later versions.

        cos Konstantin Boudnik added a comment -

        Interesting: looks like this test is passing on the Apache build system https://builds.apache.org/job/Bigtop-trunk-iTest/
        I wonder if this might be caused by different Java versions. If so then we might be better of by not relying on the particular exception message bur just on the IOException being thrown?


          People

          • Assignee:
            dasha.boudnik Dasha Boudnik
            Reporter:
            dasha.boudnik Dasha Boudnik
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development