Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 0.9.0
    • Fix Version/s: 1.0.0
    • Component/s: build
    • Labels:
      None

      Description

      Spark does not compile anymore since the dependency mqtt-client-0.4.0 has been removed from the eclipse repository.

      See yourself:
      https://repo.eclipse.org/content/repositories/paho-releases/org/eclipse/paho/mqtt-client/0.4.0/

      I did not find a different repository providing it. Since I accidentially removed my maven cache I connot compile bigtop any more.

      IMHO The options are:

      • Removing spark
      • Removing mqtt-client-dependency
      • Looking into whether upgrading spark solves this issue
      • Providing the needed jar by bigtop itself
      • Uploading the jar to some other repository and adding a new repo to the spark build
      • Asking eclipse to reestablish this artifact

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              oflebbe Olaf Flebbe
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: