Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-1547

Confirm tachyon functioning in vagrant recipes.

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 1.0.0
    • Fix Version/s: 1.0.0
    • Component/s: vm
    • Labels:
      None

      Description

      We have puppet recipes which install and setup tachyon at a basic level.

      Lets wire them into HDFS directly, so that we can run our smoke tests against a hadoop cluster which has tachyon enabled and installed, by simply calling our favorite vagrant up command and watching the show unfold for us.

      Evans Ye CC on this as you expressed interest in learning more about tacyhon . David Capwell Henry Saputra and Huamin Chen might have feedback to questions you have on the tachyon deployment architecture itself.

        Issue Links

          Activity

          jayunit100 jay vyas added a comment - - edited

          Outline of this task..

          First, setup a vagrant environment w/ tachyon added as yum repo to it:

          • To test, you must build tachyon locally and add as a yum repo in the VM, that can be done following
          • vagrant up to create a vm from vm/bigtop-deploy/vagrant-puppet, then
          • gradlew tacyhon-yum to create a yum repo for the tachyon package from source
            then vagrant ssh
            Now, ON THE VM:
          • run {{sudo yum-config-manager --add-repo file:///bigtop-home/output/ }} .

          Now: run puppet apply -d --confdir=/vagrant --modulepath=/bigtop-home/bigtop-deploy/puppet/modules /bigtop-home/bigtop-deploy/puppet/manifests/site.pp and

          • Confirm that puppet is properly and reproducibly setting up slave to properly point to master so no manual config is required.
          • Add a "tachyon" option to the vagrant recipe, which , when turned on, allows the in memory cache above the running HCFS.

          Please add questions in this thread, since tachyon is new, there may be some good insight we can discuss around preferred testing scenario.

          jayunit100 jay vyas added a comment -

          blocked by the puppet update + smoke tests ,

          jayunit100 jay vyas added a comment -

          dupe of BIGTOP-1572, closing.


            People

            • Assignee:
              jayunit100 jay vyas
              Reporter:
              jayunit100 jay vyas
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development