Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-1541

Support Debian jessie in Bigtop_toolchain; cleanup of pp files

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 1.0.0
    • Component/s: build
    • Labels:
      None
    • Environment:

      Debian Jessie (testing to be released in ~ February)

      Description

      BTW: In order to bootstrap Debian jessie in Docker, use

      mkimage.sh -t $USER/minbase debootstrap --variant=minbase jessie
      

      mkimage.sh is supplied by docker itself

      The patcheset includes some cleanup of puppet code: Removing JDK1.6, moving protobuf to protobuf.pp etc.

        Activity

        Hide
        rvs Roman Shaposhnik added a comment -

        +1 and committed.

        Show
        rvs Roman Shaposhnik added a comment - +1 and committed.
        Hide
        oflebbe Olaf Flebbe added a comment -

        Only tested on debian

        Show
        oflebbe Olaf Flebbe added a comment - Only tested on debian
        Hide
        oflebbe Olaf Flebbe added a comment -

        Yep, there are merge conflicts because of integration of Amazon Linux.. I have to retest...

        Show
        oflebbe Olaf Flebbe added a comment - Yep, there are merge conflicts because of integration of Amazon Linux.. I have to retest...
        Hide
        rvs Roman Shaposhnik added a comment -

        Olaf Flebbe could you please consolidate these patches into one so I can review/apply more easily?

        Show
        rvs Roman Shaposhnik added a comment - Olaf Flebbe could you please consolidate these patches into one so I can review/apply more easily?
        Hide
        oflebbe Olaf Flebbe added a comment -

        I removed the 0003 patch since I discovered that protobuf Version 2.5.0 is needed by hadoop. The version from die distro "jessie" is 2.6.1 ... So I refactored the protobuf installation to the same as in ubuntu

        Show
        oflebbe Olaf Flebbe added a comment - I removed the 0003 patch since I discovered that protobuf Version 2.5.0 is needed by hadoop. The version from die distro "jessie" is 2.6.1 ... So I refactored the protobuf installation to the same as in ubuntu

          People

          • Assignee:
            oflebbe Olaf Flebbe
            Reporter:
            oflebbe Olaf Flebbe
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development