Details

    • Sub-task
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 0.8.0
    • 1.0.0
    • general
    • None
    • Started and configured hive server, oozie, namenodes ....

    Description

      Important

      The following text is outdated. It refers to Hue 3.6. It was consensus to fix it by updating hue to 3.7.

      While Updating to 3.7. unfortunatelty a patch is needed which didn't get into the 3.7 release in time

      The hive editor beeswax is broken because the file

      /usr/lib/hue/apps/beeswax/src/beeswax/templates/execute.mako

      includes references to impala and impala is not supplied by bigtop.

      For instance

        from impala import conf as impala_conf
      

      or line 2280

      % if ( app_name == 'beeswax' and beeswax_conf.CLOSE_QUERIES.get() ) or ( app_name == 'impala' and impala_conf.CLOSE_QUERIES.get() ):
      

      -

      Attachments

        1. 0001-BIGTOP-1486.-Upgrade-Hue-to-3.7.patch
          12 kB
          Olaf Flebbe
        2. 0001-BIGTOP-1480.-Upgrade-Hue-to-3.7.patch
          24 kB
          Olaf Flebbe
        3. 0001-BIGTOP-1480.-Upgrade-hue-to-3.7.patch
          22 kB
          Olaf Flebbe
        4. 0001-BIGTOP-1480.-Upgrade-hue-to-3.7.patch
          20 kB
          Olaf Flebbe
        5. 0001-BIGTOP-1480.-Upgrade-hue-to-3.7.patch
          19 kB
          Olaf Flebbe
        6. 0001-BIGTOP-1480.-Upgrade-hue-to-3.7.patch
          8 kB
          Olaf Flebbe
        7. hue.patch
          1 kB
          Olaf Flebbe

        Activity

          People

            oflebbe Olaf Flebbe
            oflebbe Olaf Flebbe
            Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: