Bigtop
  1. Bigtop
  2. BIGTOP-1361

Cannot build Debian packages for Hive 0.13.x

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: None
    • Component/s: debian
    • Labels:
      None

      Description

      I'm running into a couple of problems building Debian packages for Hive 0.13x, each relating to new files in the tarball.

      • There's a directory called docs/changes, which is interpreted a special way by Debian, so we need to change the name of that directory to something before dh_installchangelogs runs.
      • There's a directory called metastore, and rules file has a target called "metastore" which consequently no longers gets called, so we need to identify it as .PHONY

        Activity

        Hide
        Sean Mackrory added a comment -

        Pushed and committed...

        Show
        Sean Mackrory added a comment - Pushed and committed...
        Hide
        Roman Shaposhnik added a comment -

        Sean Mackrory there goes my 'mayor of Make' badge

        +1

        Show
        Roman Shaposhnik added a comment - Sean Mackrory there goes my 'mayor of Make' badge +1
        Sean Mackrory made changes -
        Hide
        Sean Mackrory added a comment -

        This is truly embarrassing, but I have actually done a full hive build using master + just this patch, and uncovered another error. But at least it's really been tested properly this time. Can I trouble you for 1 more +1?

        Show
        Sean Mackrory added a comment - This is truly embarrassing, but I have actually done a full hive build using master + just this patch, and uncovered another error. But at least it's really been tested properly this time. Can I trouble you for 1 more +1?
        Hide
        Roman Shaposhnik added a comment -

        +1. Please commit.

        Show
        Roman Shaposhnik added a comment - +1. Please commit.
        Sean Mackrory made changes -
        Hide
        Sean Mackrory added a comment -

        I did test it, but it would seem the patch I submitted included code pasted from the saved patch I had tested, whereby the underscores I have vim use to distinguish between tabs and spaces ended up in the patch instead of the real tabs...

        Thanks Julien Eid for noticing this.

        Show
        Sean Mackrory added a comment - I did test it, but it would seem the patch I submitted included code pasted from the saved patch I had tested, whereby the underscores I have vim use to distinguish between tabs and spaces ended up in the patch instead of the real tabs... Thanks Julien Eid for noticing this.
        Sean Mackrory made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Hide
        Konstantin Boudnik added a comment - - edited

        +1 - looks good - didn't test it though.

        Show
        Konstantin Boudnik added a comment - - edited +1 - looks good - didn't test it though.
        Sean Mackrory made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Sean Mackrory made changes -
        Field Original Value New Value
        Attachment 0001-BIGTOP-1361.-Cannot-build-Debian-packages-for-hive-0.patch [ 12653687 ]
        Sean Mackrory created issue -

          People

          • Assignee:
            Sean Mackrory
            Reporter:
            Sean Mackrory
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development