Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-1274

yarn ResourceManager should be started before starting NodeManagers

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 0.7.0
    • Fix Version/s: 0.8.0
    • Component/s: deployment
    • Labels:
      None

      Description

      Yarn NodeManager failed to start up while using bigtop-puppet to deploy a hadoop cluster with yarn required:

      debug: Service[hadoop-yarn-nodemanager](provider=redhat): Executing '/sbin/service hadoop-yarn-nodemanager start'
      err: /Stage[main]/Hadoop_worker_node/Hadoop::Nodemanager[nodemanager]/Service[hadoop-yarn-nodemanager]/ensure: change from stopped to running failed: Could not start Service[hadoop-yarn-nodemanager]: Execution of '/sbin/service hadoop-yarn-nodemanager start' returned 1:  at /tmp/vagrant-puppet/modules-0/hadoop/manifests/init.pp:530
      

      This is caused by starting up NodeMangers before ResourceManager gets ready.

      The reproduce steps can completely leverage the vagrant-puppet snippets delivered in BIGTOP-1178:

      1.) Add components you would like to have by modifying provision.sh

      ...
      jdk_package_name,java-1.7.0-openjdk-devel.x86_64
      components,hadoop,hbase,yarn,mapred-app
      EOF
      ...
      

      2.) Spin up the cluster

      $ ./startup.sh --cluster
      

        Activity

        mgrover Mark Grover added a comment -

        +1
        Thanks Evans


          People

          • Assignee:
            evans_ye Evans Ye
            Reporter:
            evans_ye Evans Ye
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development