Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-1258

Spark puppet deploy might fail as /etc/spark can not be created

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 0.7.0
    • Fix Version/s: 0.8.0
    • Component/s: deployment
    • Labels:
      None

      Description

      On a couple of occasions I've seen puppet deployment failing because /etc/spark/conf failed to be created during the package install.

      Just to make the deployment more bulletproof I'd suggest the recipe to explicitly take care about this issue and create the hierarchy.

      1. BIGTOP-1258.patch
        0.8 kB
        Konstantin Boudnik

        Activity

        plinnell Peter Linnell added a comment -

        +1 on the patch, but that begs the question that we should look into why the package does not create or own the directories properly. Is this on .deb or .rpm packages ?

        cos Konstantin Boudnik added a comment -

        That was my first thought as well (I am playing with rpms atm). All directories seem to be there. E.g. when I install a package manually on a clean system - I see these directories created (/methinks). However, once in a while - I believe because of some earlier errors or something - they aren't and then the whole thing comes down. I will validate once again later tonight if my scenario is correct. If I can tight this up to the package - I will fix that one. Otherwise I will commit this patch.

        mgrover Mark Grover added a comment -

        Cos, thanks for this. If you could post the error with the puppet deployment when it happens next time, that'd be great. It seems like the patch may possibly mask legitimate errors in the future. What do you think?

        cos Konstantin Boudnik added a comment -

        I've tried to reproduce it and I don't see it anymore. Let's close this as 'not a bug' for now. If I see it - I will reopen the ticket.

        Guys, in the meanwhile - please take a look at BIGTOP-1259 - which is the real deployment issue.

        cos Konstantin Boudnik added a comment -

        I don't see it anymore - perhaps it was a one time glitch of a kind.


          People

          • Assignee:
            Unassigned
            Reporter:
            cos Konstantin Boudnik
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development