Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-1153

Crunch package doesn't depend on anything

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.7.0
    • Fix Version/s: 0.8.0
    • Component/s: debian, rpm
    • Labels:
      None

      Description

      The Crunch package doesn't have any dependencies.

      I think at the very least it should have bigtop-utils and hadoop-client as its dependencies.

        Issue Links

          Activity

          Hide
          jeid Julien Eid added a comment -

          I would like to work on this issue. Currently blocked on getting a successful build until 1350 gets resolved and merged though.

          Show
          jeid Julien Eid added a comment - I would like to work on this issue. Currently blocked on getting a successful build until 1350 gets resolved and merged though.
          Hide
          mgrover Mark Grover added a comment -

          Assigned to you, Julien, thanks! I haven't done any work on it yet and the other issue you mentioned has a patch attached so if you can try that out, that'd be great.

          Show
          mgrover Mark Grover added a comment - Assigned to you, Julien, thanks! I haven't done any work on it yet and the other issue you mentioned has a patch attached so if you can try that out, that'd be great.
          Hide
          jeid Julien Eid added a comment -

          Added requires bigtop-utils and hadoop-client.

          bash-4.1# rpm -qpR crunch-0.10.0-1.el6.noarch.rpm
          bigtop-utils >= 0.7
          hadoop-client
          rpmlib(CompressedFileNames) <= 3.0.4-1
          rpmlib(FileDigests) <= 4.6.0-1
          rpmlib(PayloadFilesHavePrefix) <= 4.0-1
          rpmlib(PayloadIsXz) <= 5.2-1

          Show
          jeid Julien Eid added a comment - Added requires bigtop-utils and hadoop-client. bash-4.1# rpm -qpR crunch-0.10.0-1.el6.noarch.rpm bigtop-utils >= 0.7 hadoop-client rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(FileDigests) <= 4.6.0-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(PayloadIsXz) <= 5.2-1
          Hide
          mgrover Mark Grover added a comment -

          +1, and committed. Thanks Julien!

          Show
          mgrover Mark Grover added a comment - +1, and committed. Thanks Julien!

            People

            • Assignee:
              jeid Julien Eid
              Reporter:
              mgrover Mark Grover
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development