Beehive
  1. Beehive
  2. BEEHIVE-745

methods with same name in JWS cause NPE during WSDL gen

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: v1m1
    • Fix Version/s: 1.0.1
    • Component/s: Web Services (181)
    • Labels:
      None
    • Environment:
      Beehive SVN 170442, Tomcat 5.0.28

      Description

      The JSR 181 Specification (section 5.4.1.3) provides and example of a Web service and uses the same method name for all three methods. An operationName is set for each of the WebMethods and the example compiles okay. When attempting to pull up the WSDL, the server throws an NPE.

      Clip from catalina.out:
      16 May 2005 21:27:40,206 DEBUG SimpleChain []: Exit: SimpleChain::generateWSDL
      16 May 2005 21:27:40,206 DEBUG SimpleChain []: Exit: SimpleChain::generateWSDL
      16 May 2005 21:27:40,214 DEBUG SimpleChain []: Enter: SimpleChain::generateWSDL
      16 May 2005 21:27:40,214 DEBUG SimpleChain []: Enter: SimpleChain::generateWSDL
      16 May 2005 21:27:40,363 DEBUG OperationDesc []: @1c6d11asetReturnType(null)
      16 May 2005 21:27:40,363 DEBUG OperationDesc []: @1c6d11asetReturnType(null)
      16 May 2005 21:27:40,384 DEBUG OperationDesc []: @1c6d11a added parameter >name: p
      typeEntry: null
      mode: IN
      position: 0
      isReturn: false
      typeQName: null
      javaType: class web.PingDocument
      inHeader: false
      outHeader: false
      @116318b<total parameters:1
      16 May 2005 21:27:40,384 DEBUG OperationDesc []: @1c6d11a added parameter >name: p
      typeEntry: null
      mode: IN
      position: 0
      isReturn: false
      typeQName: null
      javaType: class web.PingDocument
      inHeader: false
      outHeader: false
      @116318b<total parameters:1
      16 May 2005 21:27:40,385 DEBUG OperationDesc []: @ec436setReturnType(null)
      16 May 2005 21:27:40,385 DEBUG OperationDesc []: @ec436setReturnType(null)
      16 May 2005 21:27:40,389 DEBUG OperationDesc []: @ec436 added parameter >name: p
      typeEntry: null
      mode: INOUT
      position: 0
      isReturn: false
      typeQName: null
      javaType: class web.PingDocumentHolder
      inHeader: false
      outHeader: false
      @173eca6<total parameters:1
      16 May 2005 21:27:40,389 DEBUG OperationDesc []: @ec436 added parameter >name: p
      typeEntry: null
      mode: INOUT
      position: 0
      isReturn: false
      typeQName: null
      javaType: class web.PingDocumentHolder
      inHeader: false
      outHeader: false
      @173eca6<total parameters:1
      16 May 2005 21:27:40,389 DEBUG OperationDesc []: @1b5a5cfsetReturnType(null)
      16 May 2005 21:27:40,389 DEBUG OperationDesc []: @1b5a5cfsetReturnType(null)
      16 May 2005 21:27:40,389 DEBUG OperationDesc []: @1b5a5cf added parameter >name: p
      typeEntry: null
      mode: IN
      position: 0
      isReturn: false
      typeQName: null
      javaType: class web.PingDocument
      inHeader: false
      outHeader: false
      @98bbf6<total parameters:1
      16 May 2005 21:27:40,389 DEBUG OperationDesc []: @1b5a5cf added parameter >name: p
      typeEntry: null
      mode: IN
      position: 0
      isReturn: false
      typeQName: null
      javaType: class web.PingDocument
      inHeader: false
      outHeader: false
      @98bbf6<total parameters:1
      16 May 2005 21:27:40,390 DEBUG OperationDesc []: @1b5a5cf added parameter >name: secHdr
      typeEntry: null
      mode: IN
      position: 1
      isReturn: false
      typeQName: null
      javaType: class web.SecurityHeader
      inHeader: false
      outHeader: false
      @15c40eb<total parameters:2
      16 May 2005 21:27:40,390 DEBUG OperationDesc []: @1b5a5cf added parameter >name: secHdr
      typeEntry: null
      mode: IN
      position: 1
      isReturn: false
      typeQName: null
      javaType: class web.SecurityHeader
      inHeader: false
      outHeader: false
      @15c40eb<total parameters:2
      16 May 2005 21:27:40,390 DEBUG OperationDesc []: @1c6d11asetReturnType(null)
      16 May 2005 21:27:40,390 DEBUG OperationDesc []: @1c6d11asetReturnType(null)
      16 May 2005 21:27:40,615 DEBUG ProjectResourceBundle []: org.apache.axis.i18n.resource::handleGetObject(attachEnabled)
      16 May 2005 21:27:40,615 DEBUG ProjectResourceBundle []: org.apache.axis.i18n.resource::handleGetObject(attachEnabled)
      16 May 2005 21:27:40,616 DEBUG Message []: Attachment support is enabled? false
      16 May 2005 21:27:40,616 DEBUG Message []: Attachment support is enabled? false
      16 May 2005 21:27:40,651 DEBUG SOAPPart []: Enter: SOAPPart ctor(FORM_FAULT)
      16 May 2005 21:27:40,651 DEBUG SOAPPart []: Enter: SOAPPart ctor(FORM_FAULT)
      16 May 2005 21:27:40,652 DEBUG ProjectResourceBundle []: org.apache.axis.i18n.resource::handleGetObject(setMsgForm)
      16 May 2005 21:27:40,652 DEBUG ProjectResourceBundle []: org.apache.axis.i18n.resource::handleGetObject(setMsgForm)
      16 May 2005 21:27:40,652 DEBUG SOAPPart []: Setting current message form to: FORM_FAULT (currentMessage is now org.apache.axis.AxisFault)
      16 May 2005 21:27:40,652 DEBUG SOAPPart []: Setting current message form to: FORM_FAULT (currentMessage is now org.apache.axis.AxisFault)
      16 May 2005 21:27:40,652 DEBUG SOAPPart []: Exit: SOAPPart ctor()
      16 May 2005 21:27:40,652 DEBUG SOAPPart []: Exit: SOAPPart ctor()
      16 May 2005 21:27:40,652 DEBUG ProjectResourceBundle []: org.apache.axis.i18n.resource::handleGetObject(error00)
      16 May 2005 21:27:40,652 DEBUG ProjectResourceBundle []: org.apache.axis.i18n.resource::handleGetObject(error00)
      16 May 2005 21:27:40,656 DEBUG ProjectResourceBundle []: org.apache.axis.i18n.resource::handleGetObject(somethingWrong00)
      16 May 2005 21:27:40,656 DEBUG ProjectResourceBundle []: org.apache.axis.i18n.resource::handleGetObject(somethingWrong00)
      16 May 2005 21:27:40,656 DEBUG ProjectResourceBundle []: org.apache.axis.i18n.resource::handleGetObject(axisFault00)
      16 May 2005 21:27:40,656 DEBUG ProjectResourceBundle []: org.apache.axis.i18n.resource::handleGetObject(axisFault00)
      16 May 2005 21:27:40,659 DEBUG EXCEPTIONS []: AxisFault:
      16 May 2005 21:27:40,681 DEBUG NSStack []: NSPush (32)
      16 May 2005 21:27:40,681 DEBUG NSStack []: NSPush (32)
      16 May 2005 21:27:40,682 DEBUG ProjectResourceBundle []: org.apache.axis.i18n.resource::handleGetObject(empty00)
      16 May 2005 21:27:40,682 DEBUG ProjectResourceBundle []: org.apache.axis.i18n.resource::handleGetObject(empty00)
      16 May 2005 21:27:40,682 DEBUG NSStack []: NSPop (empty)
      16 May 2005 21:27:40,682 DEBUG NSStack []: NSPop (empty)
      16 May 2005 21:27:40,682 DEBUG NSStack []: NSPush (32)
      16 May 2005 21:27:40,682 DEBUG NSStack []: NSPush (32)
      16 May 2005 21:27:40,687 DEBUG ProjectResourceBundle []: org.apache.axis.i18n.resource::handleGetObject(empty00)
      16 May 2005 21:27:40,687 DEBUG ProjectResourceBundle []: org.apache.axis.i18n.resource::handleGetObject(empty00)
      16 May 2005 21:27:40,688 DEBUG NSStack []: NSPop (empty)
      16 May 2005 21:27:40,688 DEBUG NSStack []: NSPop (empty)
      AxisFault
      faultCode:

      {http://schemas.xmlsoap.org/soap/envelope/}

      Server.userException
      faultSubcode:
      faultString: java.lang.NullPointerException
      faultActor:
      faultNode:
      faultDetail:

      {http://xml.apache.org/axis/}

      stackTrace:java.lang.NullPointerException
      at org.apache.beehive.wsm.axis.AxisHook.createServiceDesc(AxisHook.java:145)
      at org.apache.beehive.wsm.axis.handlers.AnnotatedWebServiceDeploymentHandler.createSOAPService(AnnotatedWebServiceDeploymentHandler.java:164)
      at org.apache.beehive.wsm.axis.handlers.AnnotatedWebServiceDeploymentHandler.getSOAPService(AnnotatedWebServiceDeploymentHandler.java:121)
      at org.apache.beehive.wsm.axis.handlers.AnnotatedWebServiceDeploymentHandler.invoke(AnnotatedWebServiceDeploymentHandler.java:83)
      at org.apache.beehive.wsm.axis.handlers.AnnotatedWebServiceDeploymentHandler.generateWSDL(AnnotatedWebServiceDeploymentHandler.java:108)
      at org.apache.axis.strategies.WSDLGenStrategy.visit(WSDLGenStrategy.java:33)
      at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
      at org.apache.axis.SimpleChain.generateWSDL(SimpleChain.java:104)
      at org.apache.axis.server.AxisServer.generateWSDL(AxisServer.java:454)
      at org.apache.axis.transport.http.QSWSDLHandler.invoke(QSWSDLHandler.java:68)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.axis.transport.http.AxisServlet.processQuery(AxisServlet.java:1217)
      at org.apache.axis.transport.http.AxisServlet.doGet(AxisServlet.java:249)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
      at org.apache.axis.transport.http.AxisServletBase.service(AxisServletBase.java:327)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:237)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
      at org.apache.beehive.controls.runtime.servlet.ControlFilter.doFilter(ControlFilter.java:131)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214)
      at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
      at org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:198)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:152)
      at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137)
      at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:118)
      at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:102)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
      at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:929)
      at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160)
      at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:799)
      at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:705)
      at org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:577)
      at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:683)
      at java.lang.Thread.run(Thread.java:595)

      {http://xml.apache.org/axis/}

      hostname:localhost.localdomain

      java.lang.NullPointerException
      at org.apache.axis.AxisFault.makeFault(AxisFault.java:101)
      at org.apache.beehive.wsm.axis.handlers.AnnotatedWebServiceDeploymentHandler.invoke(AnnotatedWebServiceDeploymentHandler.java:99)
      at org.apache.beehive.wsm.axis.handlers.AnnotatedWebServiceDeploymentHandler.generateWSDL(AnnotatedWebServiceDeploymentHandler.java:108)
      at org.apache.axis.strategies.WSDLGenStrategy.visit(WSDLGenStrategy.java:33)
      at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
      at org.apache.axis.SimpleChain.generateWSDL(SimpleChain.java:104)
      at org.apache.axis.server.AxisServer.generateWSDL(AxisServer.java:454)
      at org.apache.axis.transport.http.QSWSDLHandler.invoke(QSWSDLHandler.java:68)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.axis.transport.http.AxisServlet.processQuery(AxisServlet.java:1217)
      at org.apache.axis.transport.http.AxisServlet.doGet(AxisServlet.java:249)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
      at org.apache.axis.transport.http.AxisServletBase.service(AxisServletBase.java:327)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:237)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
      at org.apache.beehive.controls.runtime.servlet.ControlFilter.doFilter(ControlFilter.java:131)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214)
      at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
      at org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:198)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:152)
      at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137)
      at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:118)
      at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:102)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
      at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:929)
      at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160)
      at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:799)
      at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:705)
      at org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:577)
      at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:683)
      at java.lang.Thread.run(Thread.java:595)
      Caused by: java.lang.NullPointerException
      at org.apache.beehive.wsm.axis.AxisHook.createServiceDesc(AxisHook.java:145)
      at org.apache.beehive.wsm.axis.handlers.AnnotatedWebServiceDeploymentHandler.createSOAPService(AnnotatedWebServiceDeploymentHandler.java:164)
      at org.apache.beehive.wsm.axis.handlers.AnnotatedWebServiceDeploymentHandler.getSOAPService(AnnotatedWebServiceDeploymentHandler.java:121)
      at org.apache.beehive.wsm.axis.handlers.AnnotatedWebServiceDeploymentHandler.invoke(AnnotatedWebServiceDeploymentHandler.java:83)
      ... 42 more
      16 May 2005 21:27:40,659 DEBUG EXCEPTIONS []: AxisFault:
      AxisFault
      faultCode:

      {http://schemas.xmlsoap.org/soap/envelope/}

      Server.userException
      faultSubcode:
      faultString: java.lang.NullPointerException
      faultActor:
      faultNode:
      faultDetail:

      {http://xml.apache.org/axis/}

      stackTrace:java.lang.NullPointerException
      at org.apache.beehive.wsm.axis.AxisHook.createServiceDesc(AxisHook.java:145)
      at org.apache.beehive.wsm.axis.handlers.AnnotatedWebServiceDeploymentHandler.createSOAPService(AnnotatedWebServiceDeploymentHandler.java:164)
      at org.apache.beehive.wsm.axis.handlers.AnnotatedWebServiceDeploymentHandler.getSOAPService(AnnotatedWebServiceDeploymentHandler.java:121)
      at org.apache.beehive.wsm.axis.handlers.AnnotatedWebServiceDeploymentHandler.invoke(AnnotatedWebServiceDeploymentHandler.java:83)
      at org.apache.beehive.wsm.axis.handlers.AnnotatedWebServiceDeploymentHandler.generateWSDL(AnnotatedWebServiceDeploymentHandler.java:108)
      at org.apache.axis.strategies.WSDLGenStrategy.visit(WSDLGenStrategy.java:33)
      at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
      at org.apache.axis.SimpleChain.generateWSDL(SimpleChain.java:104)
      at org.apache.axis.server.AxisServer.generateWSDL(AxisServer.java:454)
      at org.apache.axis.transport.http.QSWSDLHandler.invoke(QSWSDLHandler.java:68)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.axis.transport.http.AxisServlet.processQuery(AxisServlet.java:1217)
      at org.apache.axis.transport.http.AxisServlet.doGet(AxisServlet.java:249)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
      at org.apache.axis.transport.http.AxisServletBase.service(AxisServletBase.java:327)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:237)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
      at org.apache.beehive.controls.runtime.servlet.ControlFilter.doFilter(ControlFilter.java:131)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214)
      at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
      at org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:198)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:152)
      at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137)
      at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:118)
      at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:102)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
      at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:929)
      at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160)
      at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:799)
      at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:705)
      at org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:577)
      at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:683)
      at java.lang.Thread.run(Thread.java:595)

      {http://xml.apache.org/axis/}

      hostname:localhost.localdomain

      java.lang.NullPointerException
      at org.apache.axis.AxisFault.makeFault(AxisFault.java:101)
      at org.apache.beehive.wsm.axis.handlers.AnnotatedWebServiceDeploymentHandler.invoke(AnnotatedWebServiceDeploymentHandler.java:99)
      at org.apache.beehive.wsm.axis.handlers.AnnotatedWebServiceDeploymentHandler.generateWSDL(AnnotatedWebServiceDeploymentHandler.java:108)
      at org.apache.axis.strategies.WSDLGenStrategy.visit(WSDLGenStrategy.java:33)
      at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
      at org.apache.axis.SimpleChain.generateWSDL(SimpleChain.java:104)
      at org.apache.axis.server.AxisServer.generateWSDL(AxisServer.java:454)
      at org.apache.axis.transport.http.QSWSDLHandler.invoke(QSWSDLHandler.java:68)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.axis.transport.http.AxisServlet.processQuery(AxisServlet.java:1217)
      at org.apache.axis.transport.http.AxisServlet.doGet(AxisServlet.java:249)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
      at org.apache.axis.transport.http.AxisServletBase.service(AxisServletBase.java:327)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:237)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
      at org.apache.beehive.controls.runtime.servlet.ControlFilter.doFilter(ControlFilter.java:131)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214)
      at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
      at org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:198)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:152)
      at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137)
      at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:118)
      at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:102)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
      at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:929)
      at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160)
      at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:799)
      at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:705)
      at org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:577)
      at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:683)
      at java.lang.Thread.run(Thread.java:595)
      Caused by: java.lang.NullPointerException
      at org.apache.beehive.wsm.axis.AxisHook.createServiceDesc(AxisHook.java:145)
      at org.apache.beehive.wsm.axis.handlers.AnnotatedWebServiceDeploymentHandler.createSOAPService(AnnotatedWebServiceDeploymentHandler.java:164)
      at org.apache.beehive.wsm.axis.handlers.AnnotatedWebServiceDeploymentHandler.getSOAPService(AnnotatedWebServiceDeploymentHandler.java:121)
      at org.apache.beehive.wsm.axis.handlers.AnnotatedWebServiceDeploymentHandler.invoke(AnnotatedWebServiceDeploymentHandler.java:83)
      ... 42 more
      16 May 2005 21:27:40,691 DEBUG NSStack []: NSPush (32)
      16 May 2005 21:27:40,691 DEBUG NSStack []: NSPush (32)
      16 May 2005 21:27:40,691 DEBUG ProjectResourceBundle []: org.apache.axis.i18n.resource::handleGetObject(empty00)
      16 May 2005 21:27:40,691 DEBUG ProjectResourceBundle []: org.apache.axis.i18n.resource::handleGetObject(empty00)
      16 May 2005 21:27:40,692 DEBUG NSStack []: NSPop (empty)
      16 May 2005 21:27:40,692 DEBUG NSStack []: NSPop (empty)
      16 May 2005 21:27:41,018 DEBUG AxisServlet []: Exit: doGet()
      16 May 2005 21:27:41,018 DEBUG AxisServlet []: Exit: doGet()

      1. BEEHIVE-745.zip
        4 kB
        Chad Schoettger
      2. BEEHIVE-745.tar
        30 kB
        Jeremiah Johnson
      3. BEEHIVE-745.png
        15 kB
        Jeremiah Johnson
      4. BEEHIVE-745.diff
        12 kB
        Chad Schoettger

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        182d 23h 28m 1 Eddie O'Neil 16/Nov/05 16:38
        Eddie O'Neil made changes -
        Fix Version/s 1.1 [ 12310333 ]
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Eddie O'Neil added a comment -

        Should be fixed with SVN 344941 – added the test described in the patch from Chad.

        Chad Schoettger made changes -
        Assignee Chad Schoettger [ chad_s ] Eddie O'Neil [ ekoneil ]
        Chad Schoettger added a comment -

        Assiging to Eddie for patching.

        Chad Schoettger made changes -
        Attachment BEEHIVE-745.diff [ 12311893 ]
        Attachment BEEHIVE-745.zip [ 12311894 ]
        Chad Schoettger added a comment -

        AxisHook was not correctly processing overloaded methods in the webservice which was causing the exception.
        I have also added a new wsm unit test for webservices with overloaded methods.

        To patch:

        • Apply the BEEHIVE-745.diff file (patches AxisHook)
        • Add the new unit test files from the BEEHIVE-745.zip file.
        Chad Schoettger made changes -
        Assignee daryoush mehrtash [ dmehrtash ] Chad Schoettger [ chad_s ]
        daryoush mehrtash made changes -
        Fix Version/s V1 [ 10780 ]
        Fix Version/s TBD [ 10950 ]
        Affects Version/s V1Beta [ 10951 ]
        Affects Version/s V1 [ 10780 ]
        Jeremiah Johnson made changes -
        Attachment BEEHIVE-745.tar [ 20111 ]
        Jeremiah Johnson added a comment -

        This attachment (BEEHIVE-745.tar) will reproduce the log and error. The repro comes from a slightly modified version of the wsm-blank. If you don't have BEEHIVE_HOME set, then you will need to edit the build.properties; otherwise, do the following:

        tar xf BEEHIVE-745.tar
        ant -f BEEHIVE-745/WEB-INF/src/build.xml clean build war
        mv BEEHIVE-745.war $CATALINA_HOME/webapps
        http://localhost:8080/BEEHIVE-745/web/PingService.jws?wsdl

        If you would like to verify the work-around, then edit BEEHIVE-745/WEB-INF/src-ws/web/PingService.jws and make the Java method names unique. For example, I used ping, ping1, and ping2.

        Jeremiah Johnson made changes -
        Field Original Value New Value
        Attachment BEEHIVE-745.png [ 20110 ]
        Jeremiah Johnson added a comment -

        Here is a screen shot of the error that appears in the browser when attempting to view the WSDL.

        Jeremiah Johnson created issue -

          People

          • Assignee:
            Eddie O'Neil
            Reporter:
            Jeremiah Johnson
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development