Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: V1Beta
    • Fix Version/s: 1.0
    • Component/s: Samples
    • Labels:
      None
    • Environment:
      Windows, Tomcat

      Description

      ant -f %BEEHIVE_HOME%\samples\PetstoreDashboard\build.xml

      (NOTE: I doubt it matters but ... petstoreWeb app was successfully built and deployed to Tomcat previous to running build.xml for the dashboard.)

      Build spew in shell below
      No errors in Tomcat console-->

      (Build failed: )
      D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot>ant -f %BEEHIVE_HOME%\samples\PetstoreDashboard\build
      .xml
      Buildfile: D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\build.xml

      dirs:

      genClient:
      [wsdl2java] WSDL2Java http://localhost:8080/petstoreWeb/PetstoreInventoryManager.jws?wsdl
      [wsdl2java] Exception in thread "Thread-0" java.lang.StackOverflowError
      [wsdl2java] at java.util.HashMap.get(HashMap.java:320)
      [wsdl2java] at org.apache.axis.wsdl.symbolTable.SchemaUtils.getComplexElementExtensionBase(SchemaUtils.java:961)
      [wsdl2java] at org.apache.axis.wsdl.symbolTable.SchemaUtils.getBaseType(SchemaUtils.java:1863)
      [wsdl2java] at org.apache.axis.wsdl.toJava.JavaGeneratorFactory.javifyTypeEntryName(JavaGeneratorFactory.java:532)

      <...... Repeat above line a zillion times .......>

      compile:
      [javac] Compiling 2 source files to D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\Petst
      oreDashboard\build\classes
      [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore
      Dashboard.java:34: package org.apache.beehive.petstore does not exist
      [javac] import org.apache.beehive.petstore.PetstoreInventoryManager;
      [javac] ^
      [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore
      Dashboard.java:40: cannot find symbol
      [javac] symbol : class PetstoreInventoryManager
      [javac] location: class ui.PetStoreDashboard
      [javac] PetstoreInventoryManager store;
      [javac] ^
      [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore
      ProductView.java:51: package org.apache.beehive.petstore does not exist
      [javac] import org.apache.beehive.petstore.InvalidIdentifierException;
      [javac] ^
      [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore
      ProductView.java:52: package org.apache.beehive.petstore does not exist
      [javac] import org.apache.beehive.petstore.PetstoreInventoryManager;
      [javac] ^
      [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore
      ProductView.java:53: package org.apache.beehive.samples.petstore.model does not exist
      [javac] import org.apache.beehive.samples.petstore.model.Item;
      [javac] ^
      [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore
      ProductView.java:54: package org.apache.beehive.samples.petstore.model.ws does not exist
      [javac] import org.apache.beehive.samples.petstore.model.ws.Category;
      [javac] ^
      [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore
      ProductView.java:55: package org.apache.beehive.samples.petstore.model.ws does not exist
      [javac] import org.apache.beehive.samples.petstore.model.ws.Product;
      [javac] ^
      [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore
      Dashboard.java:44: cannot find symbol
      [javac] symbol : class PetstoreInventoryManager
      [javac] location: class ui.PetStoreDashboard
      [javac] public PetStoreDashboard(PetstoreInventoryManager store) {
      [javac] ^
      [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore
      ProductView.java:63: cannot find symbol
      [javac] symbol : class PetstoreInventoryManager
      [javac] location: class ui.PetStoreProductView
      [javac] PetstoreInventoryManager store;
      [javac] ^
      [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore
      ProductView.java:75: cannot find symbol
      [javac] symbol : class PetstoreInventoryManager
      [javac] location: class ui.PetStoreProductView
      [javac] public PetStoreProductView(PetstoreInventoryManager store) {
      [javac] ^
      [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore
      ProductView.java:264: cannot find symbol
      [javac] symbol : class Item
      [javac] location: class ui.PetStoreProductView.ProductDetailModel
      [javac] Item[] items = null;
      [javac] ^
      [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore
      ProductView.java:266: cannot find symbol
      [javac] symbol : class Product
      [javac] location: class ui.PetStoreProductView.ProductDetailModel
      [javac] public ProductDetailModel(Product product) throws RemoteException {
      [javac] ^
      [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore
      ProductView.java:239: cannot find symbol
      [javac] symbol : class Product
      [javac] location: class ui.PetStoreProductView.ProductItemView
      [javac] public void setProductItem(Product product) {
      [javac] ^
      [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore
      ProductView.java:364: cannot find symbol
      [javac] symbol : class Category
      [javac] location: class ui.PetStoreProductView.ProductCategoryInfo
      [javac] Category category;
      [javac] ^
      [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore
      ProductView.java:369: cannot find symbol
      [javac] symbol : class Category
      [javac] location: class ui.PetStoreProductView.ProductCategoryInfo
      [javac] public Category getCategory() {
      [javac] ^
      [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore
      ProductView.java:376: cannot find symbol
      [javac] symbol : class Category
      [javac] location: class ui.PetStoreProductView.ProductCategoryInfo
      [javac] public ProductCategoryInfo(Category category) {
      [javac] ^
      [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore
      ProductView.java:389: cannot find symbol
      [javac] symbol : class Product
      [javac] location: class ui.PetStoreProductView.ProductInfo
      [javac] Product product;
      [javac] ^
      [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore
      ProductView.java:394: cannot find symbol
      [javac] symbol : class Product
      [javac] location: class ui.PetStoreProductView.ProductInfo
      [javac] public Product getProduct() {
      [javac] ^
      [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore
      ProductView.java:401: cannot find symbol
      [javac] symbol : class Product
      [javac] location: class ui.PetStoreProductView.ProductInfo
      [javac] public ProductInfo(Product product)

      { [javac] ^ [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore Dashboard.java:79: cannot find symbol [javac] symbol : class PetstoreInventoryManager [javac] location: class ui.PetStoreDashboard [javac] PetstoreInventoryManager store; [javac] ^ [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore Dashboard.java:82: package org.apache.beehive.petstore does not exist [javac] store = (org.apache.beehive.petstore.PetstoreInventoryManagerSoapBindingStub) [javac] ^ [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore Dashboard.java:83: package org.apache.beehive.petstore does not exist [javac] new org.apache.beehive.petstore.PetstoreInventoryManagementServiceLocator().ge tPetstoreInventoryManager(); [javac] ^ [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore Dashboard.java:92: package org.apache.beehive.petstore does not exist [javac] ((org.apache.beehive.petstore.PetstoreInventoryManagerSoapBindingStub)store).setTimeout(60000); [javac] ^ [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore ProductView.java:144: cannot find symbol [javac] symbol : class Category [javac] location: class ui.PetStoreProductView [javac] Category[] categories = store.listCategories(); [javac] ^ [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore ProductView.java:155: cannot find symbol [javac] symbol : class Product [javac] location: class ui.PetStoreProductView [javac] Product[] products = store.listProducts(info.getCategory() [javac] ^ [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore ProductView.java:285: cannot find symbol [javac] symbol : class Item [javac] location: class ui.PetStoreProductView.ProductDetailModel [javac] Item curItem = items[row]; [javac] ^ [javac] D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\src\ui\PetStore ProductView.java:340: cannot find symbol [javac] symbol : class InvalidIdentifierException [javac] location: class ui.PetStoreProductView.ProductDetailModel [javac] }

      catch (InvalidIdentifierException e) {
      [javac] ^
      [javac] 27 errors

      BUILD FAILED
      D:\TEMP\TestingBeehive\Zips\apache-beehive-incubating-svn-snapshot\samples\PetstoreDashboard\build.xml:55: Compile faile
      d; see the compiler error output for details.

      Total time: 10 seconds

      1. BEEHIVE-360-build.xml
        1 kB
        Jeremiah Johnson
      2. BEEHIVE-360.txt
        17 kB
        Jeremiah Johnson

        Activity

        Eddie O'Neil added a comment -

        Passing along to Michael.

        Michael Merz added a comment -

        Work in progress. This appears to be a problem in the Axis code base and we're working with committers on that project to triage and fix this issue.

        Steve Tocco added a comment -

        What is the state of this defect? Is it necessary for V1?

        Jeremiah Johnson added a comment -

        Since Axis and JWS APIs have changed recently, I thought I would attempt to build this. First, I had to adjust the build script a little bit. I will attach the diff in case anyone else wants to attempt to build this.

        I don't get any complaints from Tomcat, now; however, I still can't get past the genClient step. Here is the current genClient output:

        genClient:
        [wsdl2java] - Unable to find required classes (javax.activation.DataHandler and javax.mail.internet.MimeMultipart). Attachment support is disabled.
        [wsdl2java] WSDL2Java http://localhost:8080/petstoreWeb/PetstoreInventoryManager.jws?wsdl
        [wsdl2java] java.io.IOException: Type

        {http://awt.java}

        Image is referenced but not defined.

        • jeremiah
        Jeremiah Johnson added a comment -

        Here is a patch in case anyone wants to attempt to build the dashboard. This patch should probably not be checked in because I am using an environment variable for BEEHIVE_HOME rather than the path relative to the sample distribution. This is just for anyone that wants to attempt a build of the Petstore Dashboard.

        Jeremiah Johnson added a comment -

        Here is a complete patch to make the dashboard build. This will fix the issue, in my opinion. A couple of changes were made to petstoreWeb that should be reviewed carefully, though.

        Changes to petstoreWeb:

        • I removed the ws package that was in petstore.model; attached images are now an optional attribute on Category and Product
        • the Web service was updated to remove the copying of Category to ws.Category and Product to ws.Product
        • I removed all cases that the Web methods would throw a DataStoreException
        • any Web methods that didn't have a catch on Exception or Throwable, I added a catch of Throwable and returned whatever was appropriate for an empty result - in a couple cases a SOAP fault was appropriate, but I put in a TODO and will issue a separate bug against the petstoreWeb to get that resolved

        Changes to wsm-petstore-dashboard:

        • updated for the package change noted above
        • updated the list of column names - Item has changed since last time dashboard was compiled successfully
        • replaced exception in run method with a return - stack already being logged
        • applied the temporary fix of beehive.home in build.properties - this necessary until dashboard is part of dist
        • fixed runtime classpath in build.xml to include classes directory (as opposed to just build directory)
        • fixed source location of runtime jars used in deploy.webservice.runtime

        Note that the dashboard now runs for me, but whether I click on Store or Product, it just says TBD. I assume that means that the functionality hasn't been implemented. I believe that implementation of whatever functionality that is is outside of the scope of this issue.

        One other note: if you want to validate this patch, you need to do something like the following:
        1. svn up -r168071
        2. patch -p0 < BEEHIVE-360.txt
        3. rm -rf samples/petstoreWeb/WEB-INF/src/org/apache/beehive/samples/petstore/model/ws
        3. ant clean clean.dist deploy build.dist
        4. get derby.jar, activation.jar, and mailapi.jar according to instructions on the Web site and put them all in $BEEHIVE_HOME/samples/petstoreWeb/WEB-INF/lib
        5. ant clean build war (in the $BEEHIVE_HOME/samples/pestoreWeb/WEB-INF/src directory)
        6. cp ../../../petstoreWeb.war $CATALINA_HOME/webapps
        7. find the non-dist wsm-petstore-dashboard
        8. put a copy of the activation.jar and mailapi.jar files that you downloaded earlier into the lib directory
        9. ant clean compile (in the wsm-petstore-dashboard directory)

        You should get a successful compile. If you want to see swing run, then use 'ant clean all' or just 'ant'.

        Eddie O'Neil added a comment -

        We've cut the petstore dashboard from the v1 samples unless someone wants to fix it very soon.

        Moving to TBD.

        Eddie O'Neil added a comment -

        The petstore-dashboard has been deleted until someone wants to write web services, tests, and a JUnit client for it. Closing as such.


          People

          • Assignee:
            daryoush mehrtash
            Reporter:
            Heather Stephens
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development