Beehive
  1. Beehive
  2. BEEHIVE-322

space in java, ant and/or tomcat path causes mantis failure

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: V1Beta
    • Fix Version/s: V1Beta
    • Component/s: Controls
    • Labels:
      None

      Description

      This happens on Lawrence, where there are spaces in the paths of Java, ant and Tomcat.(Program Files).

      And he sees mantis.milton.tesk returning error code 2.

      This is probably caused by the definition of task. Suggested imporvments:
      1). Put double quotes around name of executable(which is ant);
      2). Put double quotes around classpath(which can include ant).

        Activity

        jamie zyskowski added a comment -

        r154194

        James Song added a comment -

        Jamie: the change made by r154196 causes a build failure on Linux.

        http://beehive01.bea.com:9090/cruisecontrol/buildresults?log=log20050217135457

        The failure seems to be the same, except it is on Linux this time.

        and is fixed temporarily by r154222

        http://beehive01.bea.com:9090/cruisecontrol/buildresults?log=log20050217171457LBUILD.11

        jamie zyskowski added a comment -

        the linux failure is different than the original windows space-in-path issue. i'm looking into it...

        jamie zyskowski added a comment -

        r154352 should do it - sorry about the build break - controls drt passed on windows and linux


          People

          • Assignee:
            Zach Smith
            Reporter:
            James Song
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development