Beehive
  1. Beehive
  2. BEEHIVE-145

control extension: compile error when listening to inherited event

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: V1Beta
    • Fix Version/s: V1Beta
    • Component/s: Controls
    • Labels:
      None

      Description

      Problem:
      A compile error occurs when listening to the inherited event on a pageflow.
      Test file:
      (r122695)
      trunk\controls\test\webapps\controlsWeb\extension\Controller.jpf
      Line 40--Line 60

      Repro:
      uncomment this block and run "ant detailed.tests" from trunk\controls\test

        Activity

        Kyle Marvin added a comment -

        James, I cannot reproduce this problem. I uncomment the block, and see the controlsWeb app build and deploy, and the detailed tests execute (with some expected failures).

        Looking at the build output, I do notice some strange compiler errors:

        [apt] C:\src\beehive\controls\test\build\webapps\controlsWeb\WEB-INF\.tmpbeansrc\milton\pagefl
        ows\property\DrivePropertyConstraint2\ControllerClientInitializer.java:31: cannot find symbol
        [apt] symbol : class Controller
        [apt] location: package milton.pageflows.property.DrivePropertyConstraint2
        [apt] milton.pageflows.property.DrivePropertyConstraint2.Controller client)
        [apt] ^
        [apt] C:\src\beehive\controls\test\build\webapps\controlsWeb\WEB-INF\.tmpbeansrc\milton\pagefl
        ows\property\DrivePropertyConstraint2\ControllerClientInitializer.java:51: cannot find symbol
        [apt] symbol : class Controller
        [apt] location: package milton.pageflows.property.DrivePropertyConstraint2
        [apt] public static void initialize(ControlBeanContext cbc, milton.pageflows.property.Driv
        ePropertyConstraint2.Controller client)
        [apt]
        ^
        [apt] C:\src\beehive\controls\test\build\webapps\controlsWeb\WEB-INF\.tmpbeansrc\milton\pagefl
        ows\generic\DriveSimpleControl\ControllerClientInitializer.java:31: cannot find symbol
        [apt] symbol : class Controller
        [apt] location: package milton.pageflows.generic.DriveSimpleControl
        [apt] milton.pageflows.generic.DriveSimpleControl.Controller client)
        [apt] ^
        [apt] C:\src\beehive\controls\test\build\webapps\controlsWeb\WEB-INF\.tmpbeansrc\milton\pagefl
        ows\generic\DriveSimpleControl\ControllerClientInitializer.java:51: cannot find symbol
        [apt] symbol : class Controller
        [apt] location: package milton.pageflows.generic.DriveSimpleControl
        [apt] public static void initialize(ControlBeanContext cbc, milton.pageflows.generic.Drive
        SimpleControl.Controller client)

        but these appear to be coming from files in the milton.pageflows.* package. Since these aren't part of the original webapp, are these being generated by the test framework somehow??? If so, Joe or Zach should possibly investigate.

        Kyle Marvin added a comment -

        I should also mention that the above error happens all of the time and is not related to commenting/uncommenting the event handler described in the original bug.

        James Song added a comment -

        Test updated, running and passing.


          People

          • Assignee:
            James Song
            Reporter:
            James Song
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development