Uploaded image for project: 'Beam'
  1. Beam
  2. BEAM-9183

apache_beam.options.pipeline_options_test.PipelineOptionsTest.test_value_provider_options is flaky in precommits

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

      Description

      The test appears to fail in -pytest environments on precommits on several PRs:

      https://builds.apache.org/job/beam_PreCommit_Python_Phrase/1402
      https://builds.apache.org/job/beam_PreCommit_Python_Phrase/1397/
      https://builds.apache.org/job/beam_PreCommit_Python_Phrase/1405

      I was not able to reproduce it locally via:

      • python ./setup.py test -s apache_beam.options.pipeline_options_test
      • tox -e py27-cython-pytest
      • pytest apache_beam/options/pipeline_options_test.py

      Not sure what's happening.

        Attachments

          Activity

            People

            • Assignee:
              tvalentyn Valentyn Tymofieiev
              Reporter:
              tvalentyn Valentyn Tymofieiev

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 20m
                20m

                  Issue deployment