Uploaded image for project: 'Beam'
  1. Beam
  2. BEAM-8731

Update ElasticsearchIO to work with ES 7.x

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.16.0
    • Fix Version/s: Not applicable
    • Component/s: io-java-elasticsearch
    • Labels:
      None

      Description

      Attempting to run ElasticsearchIO with ES 7.x will cause the below exception:

      java.lang.RuntimeException: org.apache.beam.sdk.util.UserCodeException: java.lang.IllegalArgumentException: The Elasticsearch version to connect to is 7.x. This version of the ElasticsearchIO is only compatible with Elasticsearch v6.x, v5.x and v2.x

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                bcxb bren
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: