Details

    • Sub-task
    • Status: Resolved
    • P2
    • Resolution: Duplicate
    • None
    • Not applicable
    • sdk-py-core
    • None

    Description

      I believe this flag requires guppy which is a py2 only package. (https://github.com/apache/beam/blob/master/sdks/python/apache_beam/options/pipeline_options.py#L708)

      We may need to add a warning or something similar or find a guppy alternative (e.g. https://pypi.org/project/objgraph/ )

      Attachments

        Issue Links

          Activity

            People

              tvalentyn Valentyn Tymofieiev
              altay Ahmet Altay
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Slack

                  Issue deployment