Uploaded image for project: 'Beam'
  1. Beam
  2. BEAM-4674

Update ElasticsearchIO.java to support the current version 6.

    XMLWordPrintableJSON

    Details

      Description

      The current version only checks for versions 2 & 5.   It would fail on the current release of 6.  Im not certain but I don't think there would be any difference from 5 -> 6.

      code link

      checkArgument((backendVersion == 2 || backendVersion == 5),
      "The Elasticsearch version to connect to is %s.x. "
      + "This version of the ElasticsearchIO is only compatible with "
      + "Elasticsearch v5.x and v2.x",

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                echauchot Etienne Chauchot
                Reporter:
                blanks Jason Blanks
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: