Uploaded image for project: 'Beam'
  1. Beam
  2. BEAM-4448

--sdk_location seems to be a required parameter now in the Apache Beam Python SDK when using the DataflowRunner

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P2
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.5.0
    • Labels:
      None

      Description

      During the code import process of Apache Beam code into Google, it was discovered that the --sdk_location is a required parameter. Tests would fail with:  

      apache_beam/runners/portability/stager.py", line 513, in _download_pypi_sdk_package.format(package_name))
      RuntimeError: Please set --sdk_location command-line option or install a valid apache-beam distribution. 
      

       

        Attachments

          Activity

            People

            • Assignee:
              angoenka Ankur Goenka
              Reporter:
              lcwik Luke Cwik
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: