Uploaded image for project: 'Beam'
  1. Beam
  2. BEAM-12240

Make Beam compatible with next Java LTS version (Java 17)

Details

    Description

      The goal of this task is to validate that the Java SDK and the Java Direct Runner (and its tests) work as intended on the next Java LTS version (Java 17).

      This is the next iteration of the good old BEAM-2530

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              iemejia Ismaël Mejía
              Votes:
              2 Vote for this issue
              Watchers:
              11 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 58h 50m
                  58h 50m

                  Slack

                    Issue deployment