Uploaded image for project: 'Beam'
  1. Beam
  2. BEAM-11200

Update Go SDK version with release scripts

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P2
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: runner-dataflow, sdk-go
    • Labels:
      None

      Description

      Currently the Go SDK is notionally "unversioned" due to it's experimental state, however, a recent push in Dataflow has blocked all SDKs older than 2.21.0 from running against runner v2.

      The Go SDK has been using runner v2 since May 28th (or around the 2.21 tagging, so first really included in 2.22) https://github.com/apache/beam/pull/11207

      Jobs not using runner v2 should not be affected.

      The work around for now is to update https://github.com/apache/beam/blob/master/sdks/go/pkg/beam/runners/dataflow/dataflowlib/job.go#L128 to a version beyond "2.21.0" (say "2.26.0-dev")

       

      I'm going to update that at head to stop the problem and update the release scripts to automatically increment that version, just like we do for python.

        Attachments

          Activity

            People

            • Assignee:
              lostluck Robert Burke
              Reporter:
              lostluck Robert Burke
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 4h 10m
                4h 10m