Uploaded image for project: 'Beam'
  1. Beam
  2. BEAM-10819

Update Gradle to 6.1.1

    XMLWordPrintableJSON

    Details

      Description

      Update Gradle build wrapper to Gradle 6.1.1.

      Update build plugins to fix incompatibility:

      org.nosphere.apache.rat:0.4.0 -> 0.5.2
      com.diffplug.gradle.spotless:3.24.0 -> 3.24.2
      net.ltgt.gradle:gradle-apt-plugin:0.20 -> 0.21
      com.google.protobuf:protobuf-gradle-plugin:0.8.5 -> 0.8.8

      Replace deprecated build scan with new version:
      id 'com.gradle.build-scan' version '2.3'
      moved from build.gradle to settings.gradle and switch to new plugin
      id "com.gradle.enterprise" version "3.4.1"

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                homebrew Adam Newman
                Reporter:
                homebrew Adam Newman
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 2h
                  2h