Uploaded image for project: 'Beam'
  1. Beam
  2. BEAM-10718

Mongo DB IO benchmark is failing

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Triage Needed
    • Priority: P3
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: test-failures
    • Labels:
      None

      Description

      The benchmark must have been failing since 2.22.0 or so.

      https://ci-beam.apache.org/job/beam_python_mongoio_load_test/995/

      ```
      14:12:28 > Task :sdks:python:test-suites:dataflow:py35:mongodbioIT
      14:12:28 /home/jenkins/jenkins-slave/workspace/beam_python_mongoio_load_test/src/build/gradleenv/-1734967054/lib/python3.5/site-packages/apache_beam/_init_.py:86: UserWarning: You are using the final Apache Beam release with Python 3.5 support. New releases of Apache Beam will require Python 3.6 or a newer version.
      14:12:28 'You are using the final Apache Beam release with Python 3.5 support. '
      14:12:28 Traceback (most recent call last):
      14:12:28 File "/usr/lib/python3.5/runpy.py", line 184, in _run_module_as_main
      14:12:28 "_main_", mod_spec)
      14:12:28 File "/usr/lib/python3.5/runpy.py", line 85, in _run_code
      14:12:28 exec(code, run_globals)
      14:12:28 File "/home/jenkins/jenkins-slave/workspace/beam_python_mongoio_load_test/src/build/gradleenv/-1734967054/lib/python3.5/site-packages/apache_beam/io/mongodbio_it_test.py", line 114, in <module>
      14:12:28 run()
      14:12:28 File "/home/jenkins/jenkins-slave/workspace/beam_python_mongoio_load_test/src/build/gradleenv/-1734967054/lib/python3.5/site-packages/apache_beam/io/mongodbio_it_test.py", line 71, in run
      14:12:28 with TestPipeline(options=PipelineOptions(pipeline_args)) as p:
      14:12:28 File "/home/jenkins/jenkins-slave/workspace/beam_python_mongoio_load_test/src/build/gradleenv/-1734967054/lib/python3.5/site-packages/apache_beam/testing/test_pipeline.py", line 107, in _init_
      14:12:28 super(TestPipeline, self)._init_(runner, options)
      14:12:28 File "/home/jenkins/jenkins-slave/workspace/beam_python_mongoio_load_test/src/build/gradleenv/-1734967054/lib/python3.5/site-packages/apache_beam/pipeline.py", line 203, in _init_
      14:12:28 'Pipeline has validations errors: \n' + '\n'.join(errors))
      14:12:28 ValueError: Pipeline has validations errors:
      14:12:28 Missing required option: region.
      ```
      cc: Kamil Wasilewski What is the monitoring plan for these benchmarks? Sounds like we lose track of these failures.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              tvalentyn Valentyn Tymofieiev
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: