Currently, runtime type check errors yield error messages that display the label of a transform prefixed with 'ParDo'.
- For instance, an error in a DoFn named 'ToInt' would show up as 'ParDo(ToInt)' in the error message.
- However, this is incorrect behavior in certain cases, such as with Maps or Composite ParDo's. These should not be prefixed with 'ParDo'.
This Jira issue would update the error messages to more accurately reflect the nature of the original transform. Tests would need to be updated to reflect the new error string changes as well.