Uploaded image for project: 'Beam'
  1. Beam
  2. BEAM-10635

Incompatible google-api-core and google-cloud-bigquery

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P0
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: sdk-py-core
    • Labels:
      None

      Description

      This bigquery version bump: https://github.com/apache/beam/commit/a315672dbe2b82e013e8120ac5398c623c7b13a7

      seems to have broken the pip check:

      google-cloud-bigquery 1.26.1 has requirement google-api-core<2.0dev,>=1.21.0, but you have google-api-core 1.20.0

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ningk Ning Kang
                Reporter:
                ningk Ning Kang
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 40m
                  40m