Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.95
    • Fix Version/s: 1.0.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      Linux

      Description

      1)send attachment
      for example, the client will attach three files to the web service.
      a) The first file exists and is not empty
      b) The second file doesn't exist or it is empty.
      c) The third file exists and is not empty

      when the server receives the SOAP message, it will try to detach
      these files. But the server only can detach the first file and can
      not detach the third file. When I used the TCP MONITOR to trace the
      SOAP message, the first MIME contains the content of the first file;
      the second MIME is empty; the third MIME contains the content of the
      third file. I also check what is the content in corresponding binary
      node, I found the binary node in both second and third attachment
      node are NULL.

      2)send back attachment
      If the server would like to send back the attachment to the client in case of SEND-AND-RECEIVE message pattern, it seems that the server can not attach these files. When I used the TCP monitor to trace the SOAP message, no any MIME in the SOAP reply even if I enable the MTOM options in the server program. When I read some doucments, it seems tha tthe OPTIONS only can associate with CLIENT. How can I associate the OPTIONS with the server as well?

      1. test.c
        12 kB
        yong yang
      2. client.c
        7 kB
        yong yang
      3. axis2.h
        0.9 kB
        yong yang
      4. axis2.c
        8 kB
        yong yang
      5. ASF.LICENSE.NOT.GRANTED--image001.gif
        2 kB
        Styphinson Toms - TLS , Chennai

        Activity

        yong yang added a comment -

        this file defines the necessary functions to create AXIS2C environment, build and desseriable soap

        yong yang added a comment -

        1) axis2.h and axis2.c define the necessary functions to create AXIS2C environment, build and desserialize SOAP message
        2) client.c is the client program
        3) test.c is the server program

        Supun Kamburugamuva added a comment -

        I have fixed the problem with empty attachments. The problem was in the axiom/src/attachments/data_handler.c file. When an empty file is given axiom_data_handler_read_from function's while loop ran without stopping. I have corrected this problem so that when a empty file is given it returns a empty stream.

        Dinesh Weerapurage added a comment -

        I'm closing this issue since it is fixed. Many thanks to Supun.

        Styphinson Toms - TLS , Chennai added a comment -

        How can I construct the MIME message in SwA .I need to return an
        attachment from the server program. Is it possible

        Thanks In advance.

        THANKS,

        STYPHINSON TOMS.

        DISCLAIMER:
        -----------------------------------------------------------------------------------------------------------------------

        The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
        It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in
        this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
        Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of
        this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have
        received this email in error please delete it and notify the sender immediately. Before opening any mail and
        attachments please check them for viruses and defect.

        -----------------------------------------------------------------------------------------------------------------------


          People

          • Assignee:
            Dinesh Weerapurage
            Reporter:
            yong yang
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development