Axis2-C
  1. Axis2-C
  2. AXIS2C-348

Code generation tool gave exception when using the adb for data binding

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.96
    • Component/s: code generation
    • Labels:
      None

      Description

      following exception is given when codegen using options -l c -d adb for XSDElementNil.wsdl.
      Exception in thread "main" org.apache.axis2.wsdl.codegen.CodeGenerationException: java.lang.RuntimeException: java.lang.reflect.InvocationTargetException
      at org.apache.axis2.wsdl.codegen.CodeGenerationEngine.generate(CodeGenerationEngine.java:224)
      at org.apache.axis2.wsdl.WSDL2Code.main(WSDL2Code.java:32)
      at org.apache.axis2.wsdl.WSDL2Java.main(WSDL2Java.java:21)
      Caused by: java.lang.RuntimeException: java.lang.reflect.InvocationTargetException
      at org.apache.axis2.wsdl.codegen.extension.SimpleDBExtension.engage(SimpleDBExtension.java:52)
      at org.apache.axis2.wsdl.codegen.CodeGenerationEngine.generate(CodeGenerationEngine.java:177)
      ... 2 more
      Caused by: java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.axis2.wsdl.codegen.extension.SimpleDBExtension.engage(SimpleDBExtension.java:49)
      ... 3 more
      Caused by: org.apache.axis2.schema.SchemaCompilationException: Not implemented yet
      at org.apache.axis2.schema.writer.CStructWriter.write(CStructWriter.java:187)
      at org.apache.axis2.schema.SchemaCompiler.writeSimpleType(SchemaCompiler.java:912)
      at org.apache.axis2.schema.SchemaCompiler.processSimpleSchemaType(SchemaCompiler.java:1731)
      at org.apache.axis2.schema.SchemaCompiler.processSchema(SchemaCompiler.java:841)
      at org.apache.axis2.schema.SchemaCompiler.processElement(SchemaCompiler.java:519)
      at org.apache.axis2.schema.SchemaCompiler.processElement(SchemaCompiler.java:480)
      at org.apache.axis2.schema.SchemaCompiler.process(SchemaCompiler.java:1459)
      at org.apache.axis2.schema.SchemaCompiler.processParticle(SchemaCompiler.java:1421)
      at org.apache.axis2.schema.SchemaCompiler.processComplexType(SchemaCompiler.java:921)
      at org.apache.axis2.schema.SchemaCompiler.processAnonymousComplexSchemaType(SchemaCompiler.java:854)
      at org.apache.axis2.schema.SchemaCompiler.processSchema(SchemaCompiler.java:837)
      at org.apache.axis2.schema.SchemaCompiler.processElement(SchemaCompiler.java:519)
      at org.apache.axis2.schema.SchemaCompiler.processElement(SchemaCompiler.java:490)
      at org.apache.axis2.schema.SchemaCompiler.compile(SchemaCompiler.java:327)
      at org.apache.axis2.schema.SchemaCompiler.compile(SchemaCompiler.java:239)
      at org.apache.axis2.schema.ExtensionUtility.invoke(ExtensionUtility.java:71)
      ... 8 more

      1. XSDElementNil.wsdl
        33 kB
        Milinda Lakmal Pathirage

        Issue Links

          Activity

          Dinesh Weerapurage added a comment -

          this issue is fixed along with the patch in axis2c-365


            People

            • Assignee:
              Unassigned
              Reporter:
              Milinda Lakmal Pathirage
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development