Uploaded image for project: 'Axis2'
  1. Axis2
  2. AXIS2-5503

Axis 2 1.6.2. issues with nil="1" attribute in the request

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: adb
    • Labels:
      None

      Description

      Dear All.

      Currenly i am using axis 2 1.4.1 for generating server side stubs

      Now we are actually planning to migrate to axis 2 1.6.2

      But the problem is

      after generating the stubs, when i see the differenct between stubs of
      axis 2 1.4.1 and axis 2 1.6.2 below condition is generated(in axis 2
      1.6.2) as part of stub generation

       nillableValue =
      reader.getAttributeValue("http://www.w3.org/2001/XMLSchema-instance","nil");
                                          if ("true".equals(nillableValue)
      || "1".equals(nillableValue)){
                                              throw new
      org.apache.axis2.databinding.ADBException("The element:
      "+"custShortName" +"  cannot be null");
                                          }
      

      When i was tested, my request are failing because of this condtion
      generating for all values in XSD with the below sample request

      <urn1:bookName xsi:nil="1"/>(in Axis 2 1.6.2)

      can u pelase let me know this is problem with axis 2 1.6.2..if yes,
      can u pelase share the bug number and all

      can u pelase revert me ASAP

      Thanks in advance

      Thanks
      Phani

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                phanibharatula phanikumar
              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated: