Axis2
  1. Axis2
  2. AXIS2-5279

WSDL customization API for Axis2 and stabilize WSDL 2.0 features

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.7.0
    • Component/s: None

      Description

      This project idea consists of collection of Axis2 issues related to WSDL features and mainly focus on following two areas.

      1.) Introduce a API to customize default WSDL generation behavior of Axis2 and this need to be supported to both WSDL 1.1 and WSDL 2.0.
      2.) Stabilize WSDL 2.0 features and add missing features.

      Following are the set of issues that have been identified as compulsory tasks of this project and required to provide detailed technical design with proposals.

      AXIS2-3492 - WSDLSupplier configuration and/or check is not proper/obvious
      AXIS2-5278 - WSDLSupplier should support for both WSDL 1.1 and WSDL 2.0
      AXIS2-3653 - customization of dynamic WSDL creation
      AXIS2-5240 - Provide an API/mechanism for setting parameters for run-time Java2WSDL generation.
      AXIS2-3114 - Control what wsdl bindings returned via services.xml
      AXIS2-5191 - Axis2 should support to use "useOriginalWSDL" property for WSDL 2.0

      Further following are some of the optional tasks identified and it's expected to complete some of those issues as well ( Not required to fix following complete list of issues).

      AXIS2-4976 - Axis2 wsdl2code code generation bug caused by "localName"
      AXIS2-4407 - Axis 2 does not pick up wsdl2.0 which is modified to include whttp:location and whttp:method for Restful services
      AXIS2-4193 - WSDL2JAVA no setters in ADBBean
      AXIS2-3768 - WSDL20ToAxisServiceBuilder does not read policies in WSDL 2.0 docs
      AXIS2-3108 - Broken WSDL for operations added by modules
      AXIS2-4734 - Issue with schema import in the wsdl file
      AXIS2-4985 - NullPointerException in axis2-aar-maven-plugin if no fileSet is specified
      AXIS2-4747 - Possible bug when generating code for livebookings wsdl
      AXIS2-4521 - WSDL504,Could not locate the schema document when tomcat starts up
      AXIS2-4436 - Woden attempts to load http://www.w3.org/2001/XMLSchema.xsd every time it parses a WSDL document (or if Axis2 instructs Woden to do so)
      AXIS2-4978 - Copying data from inputStream to OuputStream needs appropriate buffer size
      AXIS2-4065 - Policy attached to an input operation in a WSDL does not get copied to the Stub operation by WSDL2Java

      1. wsdl2.patch.txt
        60 kB
        Ranjana Prasad
      2. WSDL-1.patch
        46 kB
        Ranjana Prasad
      3. test-classes.patch
        7 kB
        Ranjana Prasad

        Activity

        Sagara Gunathunga created issue -
        Sagara Gunathunga made changes -
        Field Original Value New Value
        Description This project idea consists of collection of Axis2 issues related to WSDL features and mainly focus on following two areas.

        1.) Introduce a API to customize default WSDL generation behavior of Axis2 and this need to be supported to both WSDL 1.1 and WSDL 2.0.
        2.) Stabilize WSDL 2.0 features and add missing features.


        Following are the set of issues that have been identified as compulsory tasks of this project and required to provide detailed technical design with proposals.

        AXIS2-3492 - WSDLSupplier configuration and/or check is not proper/obvious
        AXIS2-5278 - WSDLSupplier should support for both WSDL 1.1 and WSDL 2.0
        AXIS2-3653 - customization of dynamic WSDL creation
        AXIS2-5240 - Provide an API/mechanism for setting parameters for run-time Java2WSDL generation.
        AXIS2-3114 - Control what wsdl bindings returned via services.xml
        AXIS2-5191 - Axis2 should support to use "useOriginalWSDL" property for WSDL 2.0
        This project idea consists of collection of Axis2 issues related to WSDL features and mainly focus on following two areas.

        1.) Introduce a API to customize default WSDL generation behavior of Axis2 and this need to be supported to both WSDL 1.1 and WSDL 2.0.
        2.) Stabilize WSDL 2.0 features and add missing features.


        Following are the set of issues that have been identified as compulsory tasks of this project and required to provide detailed technical design with proposals.

        AXIS2-3492 - WSDLSupplier configuration and/or check is not proper/obvious
        AXIS2-5278 - WSDLSupplier should support for both WSDL 1.1 and WSDL 2.0
        AXIS2-3653 - customization of dynamic WSDL creation
        AXIS2-5240 - Provide an API/mechanism for setting parameters for run-time Java2WSDL generation.
        AXIS2-3114 - Control what wsdl bindings returned via services.xml
        AXIS2-5191 - Axis2 should support to use "useOriginalWSDL" property for WSDL 2.0


        Further following are some of the optional tasks identified and it's expected to complete some of those issues as well ( Not required to fix following complete list of issues).

        AXIS2-4976 - Axis2 wsdl2code code generation bug caused by "localName"
        AXIS2-4407 - Axis 2 does not pick up wsdl2.0 which is modified to include whttp:location and whttp:method for Restful services
        AXIS2-4193 - WSDL2JAVA no setters in ADBBean
        AXIS2-3768 - WSDL20ToAxisServiceBuilder does not read policies in WSDL 2.0 docs
        AXIS2-3108 - Broken WSDL for operations added by modules
        AXIS2-4734 - Issue with schema import in the wsdl file
        AXIS2-4985 - NullPointerException in axis2-aar-maven-plugin if no fileSet is specified
        AXIS2-4747 - Possible bug when generating code for livebookings wsdl
        AXIS2-4521 - WSDL504,Could not locate the schema document when tomcat starts up
        AXIS2-4436 - Woden attempts to load http://www.w3.org/2001/XMLSchema.xsd every time it parses a WSDL document (or if Axis2 instructs Woden to do so)
        AXIS2-4978 - Copying data from inputStream to OuputStream needs appropriate buffer size
        AXIS2-4065 - Policy attached to an input operation in a WSDL does not get copied to the Stub operation by WSDL2Java
        Sagara Gunathunga made changes -
        Labels axis-gsoc gsoc2012
        Ranjana Prasad added a comment -

        I would like to work on this issue as my GSoC project. I have some previous experience on Apache Woden project, I'm curious to know do I have to fix all issues mentioned above ? Also any advice on proposal structure ?

        Sagara Gunathunga added a comment -

        As I mentioned in above issue description you don't need to work on all issues. There are 6 issues that have been mentioned as compulsory those are interdependent and you need to address them with clear designs and implementation approaches within your proposal. Other than that it is expected to resolve some of the issue that have been mentioned as optional tasks that depends on your capacity and time availability.

        Since your are interested in this idea I would like to recommend you to go through those issues mentioned as optional and provide one or two patches before you start the project that will provide more insight on this project. Also this will add some positive points to you during the selection process. Since you have previous experience with Woden IMO it's better to try out for few WSDL 2.0 related issue first.

        Ranjana Prasad made changes -
        Attachment WSDL-1.patch [ 12535145 ]
        Ranjana Prasad added a comment -

        Hi Sagara,

        Please review attached patch which contains my progress so far.

        Thanks,

        Sagara Gunathunga added a comment -

        Following test classes are missing in your patch please attach them.

        TestWSDL11SupplierTemplate
        TestWSDL20Supplier

        Ranjana Prasad added a comment -

        Sorry for inconvenience occurred. Please find attached patch for test classes.

        Ranjana Prasad made changes -
        Attachment test-classes.patch [ 12535533 ]
        Sagara Gunathunga added a comment -

        Provided patches available on r1358606.

        Ranjana Prasad added a comment -

        Patch for WSDL 2.0 customization and test cases.

        Ranjana Prasad made changes -
        Attachment wsdl2.patch.txt [ 12541723 ]
        Sagara Gunathunga added a comment -

        Patch available on r1377218. Please make sure to build your patches on Java5

        Sagara Gunathunga made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 1.7.0 [ 12316136 ]
        Resolution Fixed [ 1 ]
        Hudson added a comment -

        Integrated in Axis2 #1736 (See https://builds.apache.org/job/Axis2/1736/)
        AXIS2-5279 - applied wsdl2 patch. (Revision 1377218)

        Result = SUCCESS
        sagara :
        Files :

        • /axis/axis2/java/core/trunk/modules/kernel/src/org/apache/axis2/dataretrieval/WSDL20SupplierTemplate.java
        • /axis/axis2/java/core/trunk/modules/kernel/src/org/apache/axis2/description/AxisService.java
        • /axis/axis2/java/core/trunk/modules/kernel/src/org/apache/axis2/description/AxisService2WSDL20.java
        • /axis/axis2/java/core/trunk/modules/kernel/src/org/apache/axis2/util/WSDLSerializationUtil.java
        • /axis/axis2/java/core/trunk/modules/kernel/test/org/apache/axis2/description/TestWSDL20SupplierTemplate.java
        • /axis/axis2/java/core/trunk/modules/kernel/test/org/apache/axis2/description/WSDLSupplierTest.java

          People

          • Assignee:
            Unassigned
            Reporter:
            Sagara Gunathunga
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development