Uploaded image for project: 'Axis2'
  1. Axis2
  2. AXIS2-5192

WSDL2Java fails generation if a SimpleType with a name of "prn" is used

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Not A Problem
    • Affects Version/s: 1.5.1, 1.6.1
    • Fix Version/s: None
    • Component/s: wsdl
    • Labels:
    • Environment:
      Windows XP SP3, Tried multiple versions of java, AXIS 1.6.1

      Description

      We have an internal identifier which is know by the name PRN (ie. PersonReferenceNumber)

      When we use an element referencing a SimpleType with the above name the WSDL2Java process hangs for numerous minutes and then fails with the following error:

      (Location of error unknown)java.io.IOException: The device is not connected.

      The problem is case-insensitive, so PRN, prn, Prn all do the same thing. Adding another letter, e.g. XPrn works just fine.

      Have tried this on Axis 1.5.1 and 1.6.1 - fails on both
      Have also tried generating using other java generation options, e.g. XMLBeans, etc - all seem to fail the same way

      Sample schema:

      <?xml version="1.0" encoding="UTF-8"?>
      <xsd:schema targetNamespace="http://police.govt.nz/interface/moj/eBench" xmlns:eb="http://police.govt.nz/interface/moj/eBench" xmlns:ic="http://police.govt.nz/interfacecommon" xmlns:chg="http://police.govt.nz/charge" xmlns:xsd="http://www.w3.org/2001/XMLSchema">

      <xsd:element name="finaliseChargeRequest">
      <xsd:complexType>
      <xsd:sequence>
      <xsd:element name="header" type="xsd:string" />
      <xsd:element name="charge" type="xsd:string" />
      <xsd:element name="namePrn" type="eb:PRN" />
      </xsd:sequence>
      </xsd:complexType>
      </xsd:element>

      <xsd:element name="finaliseChargeResponse">
      <xsd:complexType>
      <xsd:sequence>
      <xsd:element name="header" type="xsd:string" />
      </xsd:sequence>
      </xsd:complexType>
      </xsd:element>

      <xsd:simpleType name="PRN">
      <xsd:restriction base="xsd:long" />
      </xsd:simpleType>

      </xsd:schema>

      -------------------------------------
      23/11/2011 - Neil Morrison

      I've spent a bit more time investigating the problem and refined the problem down a little so it has nothing to do with WSDL2Java

      I've cut the schema down to a bare minimum:

      <?xml version="1.0" encoding="UTF-8"?>
      <xsd:schema targetNamespace="http://police.govt.nz/test" xmlns:test="http://police.govt.nz/test" xmlns:xsd="http://www.w3.org/2001/XMLSchema" elementFormDefault="qualified">

      <xsd:simpleType name="PRN">
      <xsd:restriction base="xsd:string" />
      </xsd:simpleType>

      <xsd:element name="namePrn" type="test:PRN" />

      </xsd:schema>

      And, then used the XSD2Java generator to attempt to generate it also locks up and fails after numerous minutes

      Same solution works - change the name from PRN to something like MyPRN and all works ok

      Will continue looking further - if this issue needs moving to another project let me know

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              morro Neil Morrison
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: