Axis2
  1. Axis2
  2. AXIS2-5145

Apache Axis2 Code Generator Wizard - Eclipse Plugin - Not instantiating

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.6.1
    • Fix Version/s: 1.6.2, 1.7.0
    • Component/s: ide plugins
    • Labels:
    • Environment:
      Apache Axis2 Code Generator Wizard - Eclipse Plugin

      Description

      I have downloaded org.apache.axis2.eclipse.codegen.plugin_1.6.1.zip from Apache site and installed it in the Eclipse Indigo (3.7.0) plugins folder (jar file only from the zip). After restarting eclipse, the Axis code generating wizard is not instantiated in Eclipse. Can you please direct me here?

      1. AXIS2_5145_1.6_Branch.patch
        1 kB
        Harshana Eranga Martin
      2. AXIS2_5145_Service_Plugin_Trunk.patch
        1.0 kB
        Harshana Eranga Martin

        Issue Links

          Activity

          Hudson added a comment -

          Integrated in Axis2 #1066 (See https://builds.apache.org/job/Axis2/1066/)
          AXIS2-5145: Fixed the service archiver Eclipse plugin.

          veithen :
          Files :

          • /axis/axis2/java/core/trunk/modules/tool/axis2-eclipse-service-plugin/pom.xml
          Andreas Veithen added a comment -

          Fixed by:

          • making sure that Neethi no longer references DOOM classes directly (applies to the trunk and the 1.6 branch);
          • adding an Ignore-Package instruction for com.sun.* in the service archiver plugin (trunk only).

          All 1.6.2-SNAPSHOT and 1.7.0-SNAPSHOT plugins can now be installed into Eclipse (tested with Helios SR1 JEE edition).

          Hudson added a comment -

          Integrated in axis2-1.6 #122 (See https://builds.apache.org/job/axis2-1.6/122/)
          Upgraded to Neethi 3.0.2-SNAPSHOT. This should (partially) solve AXIS2-5145.

          veithen :
          Files :

          • /axis/axis2/java/core/branches/1_6/modules/parent/pom.xml
          Hudson added a comment -

          Integrated in neethi-trunk #129 (See https://builds.apache.org/job/neethi-trunk/129/)
          Make sure that Neethi only refers to axiom-api, but never to implementation classes directly.

          This should partially solve AXIS2-5145 and contribute to the solution of AXIS2-4902.

          veithen :
          Files :

          • /webservices/commons/trunk/modules/neethi/pom.xml
          • /webservices/commons/trunk/modules/neethi/src/main/java/org/apache/neethi/builders/converters/OMToDOMConverter.java
          Harshana Eranga Martin added a comment - - edited

          AXIS2_5145_1.6_Branch.patch file contains fix for 1.6 branch.

          These plugins are broken in 1.6 branch because they contains an import package statement to org.apache.axiom.om.impl.dom. This is because they have neethi 3.0.x as a dependency.

          Hence this patch is provided to include axiom-dom to bundle classpath to satisfy the optional dependency of neethi 3.0.x.

          Harshana Eranga Martin added a comment - - edited

          AXIS2_5145_Service_Plugin_Trunk.patch file is for trunk and it fixes the axis2 eclipse service plugin.

          axis2 eclipse codegen plugin in trunk works fine.

          Harshana Eranga Martin added a comment -

          Hi Andreas,

          I tested the Axis2 trunk after building Axiom Trunk which contains your fix for MSHADE-105 and it indeed solved the issue of appearing org.apache.axiom.om.impl.common and org.apache.axiom.om.impl.common.factory in import packages. Now they no longer appears in the manifest and hence this issue is partially solved.

          I will resubmit the patches for this issue shortly.

          Thanks and Regards,
          Harshana

          Harshana Eranga Martin added a comment -

          Hi Andreas,

          Thanks for the detailed explanation and fixing the root cause. I will build the eclipse plugins again and will test.

          Thanks and Regards,
          Harshana

          Hudson added a comment -

          Integrated in ws-axiom-trunk #590 (See https://builds.apache.org/job/ws-axiom-trunk/590/)
          Implemented a workaround for MSHADE-105. This should partially solve AXIS2-5145.

          veithen :
          Files :

          • /webservices/commons/trunk/modules/axiom/modules/axiom-buildutils/pom.xml
          • /webservices/commons/trunk/modules/axiom/modules/axiom-buildutils/src/main/java/org/apache/axiom/buildutils/PluginXmlResourceTransformer.java
          • /webservices/commons/trunk/modules/axiom/modules/axiom-dom/pom.xml
          • /webservices/commons/trunk/modules/axiom/modules/axiom-impl/pom.xml
          • /webservices/commons/trunk/modules/axiom/modules/shade-plugin-patched
          • /webservices/commons/trunk/modules/axiom/modules/shade-plugin-patched/pom.xml
          • /webservices/commons/trunk/modules/axiom/modules/shade-plugin-patched/src
          • /webservices/commons/trunk/modules/axiom/modules/shade-plugin-patched/src/main
          • /webservices/commons/trunk/modules/axiom/modules/shade-plugin-patched/src/main/java
          • /webservices/commons/trunk/modules/axiom/modules/shade-plugin-patched/src/main/java/org
          • /webservices/commons/trunk/modules/axiom/modules/shade-plugin-patched/src/main/java/org/apache
          • /webservices/commons/trunk/modules/axiom/modules/shade-plugin-patched/src/main/java/org/apache/maven
          • /webservices/commons/trunk/modules/axiom/modules/shade-plugin-patched/src/main/java/org/apache/maven/plugins
          • /webservices/commons/trunk/modules/axiom/modules/shade-plugin-patched/src/main/java/org/apache/maven/plugins/shade
          • /webservices/commons/trunk/modules/axiom/modules/shade-plugin-patched/src/main/java/org/apache/maven/plugins/shade/DefaultShader.java
          • /webservices/commons/trunk/modules/axiom/pom.xml
          Andreas Veithen added a comment -

          Reference to the issue report for maven-shade-plugin:

          http://jira.codehaus.org/browse/MSHADE-105

          Andreas Veithen added a comment -

          Here is a more thorough analysis why the org.apache.axiom.om.impl.* imports started to appear in the bundle manifest:

          org.apache.axiom.om.impl.dom appears in all Axis2 versions that depend on Neethi 3.0.x and don't depend on axiom-dom, i.e. Axis2 1.6.1 and 1.6.2-SNAPSHOT (in the trunk, axis2-kernel has a dependency on axiom-dom). The reason for this is that Neethi 3.0.x has an optional dependency on axiom-dom, namely there is code that depends on DOOMAbstractFactory. That dependency is discovered by the bundle plugin, which adds an Import-Package instruction for org.apache.axiom.om.impl.dom to the manifest.

          org.apache.axiom.om.impl.common appears in all Axis2 versions that depend on Axiom 1.2.13-SNAPSHOT, i.e. Axis2 1.5.7-SNAPSHOT, 1.6.2-SNAPSHOT and 1.7.0-SNAPSHOT. The org.apache.axiom.om.impl.common package is defined by axiom-common-impl which is later shaded/relocated into axiom-impl and axiom-dom (i.e. the package is renamed). Apparently, the relocator in maven-shade-plugin doesn't clean up the constant pools of these classes and they still have entries referring to org.apache.axiom.om.impl.common. That has no consequences at runtime (because these entries in the constant pools are actually never used), but the bundle plugin still detects them and generates corresponding Import-Package instructions.

          Mario Coeckelberghs added a comment -

          Is there a target date on when these patches will be accepted and committed and when the build will be available?

          Harshana Eranga Martin added a comment -

          Hi Jacques,

          These patch files are to be applied to the source code. Hence if you have the source you can apply these patch files using "patch -p0 < PATH_TO_PATCH_FILE" command. Then you can build the source code using Maven locally.

          Once these patches are accepted and committed, you will be able to download the artifacts with the fixes from Apache Build server. (Nightly build)

          Thanks.
          Harshana

          Harshana Eranga Martin added a comment -

          Hi Andreas,

          If I did not exclude org.apache.axiom.om.impl* packages, there are 2 package imports added as org.apache.axiom.om.impl.common and org.apache.axiom.om.impl.common.factory. I'm not sure what cause these package imports.

          But these imports cannot be satisfied since none of the bundles included in the bundle classpath export these packages. Therefore the eclipse service plugin fails to start. To avoid that I included this exclusion rule.

          I can tweak the rule to exclude !org.apache.axiom.om.impl.common* specifically. Shall I do it or Is the current rule ok?

          Thanks and Regards,
          Harshana

          Jacques added a comment -

          Sorry for being an ignorant, but how does one work with the .patch files exactly ?

          Or even better question, when is the official download for the Zip file being updated with that fix ?

          Tks.

          Andreas Veithen added a comment -

          I'm a bit worried about the exclusion of org.apache.axiom.om.impl*. That doesn't make sense to me. Any explanation for this?

          Harshana Eranga Martin added a comment - - edited

          Hi Sagara,

          Yes. I tested the both patches against 1.6 branch as well. And they works. (Added both patches again)

          AXIS2-5145.patch needs to be applied to both 1.6 branch as well as Trunk. (For Axis2-eclipse-service plugin)
          AXIS2-5145_1.6_only.patch only needs to be applied to 1.6 branch. Trunk works fine. (For Axis2-eclipse-codegen plugin)

          Thanks and Regards,
          Harshana

          Sagara Gunathunga added a comment -

          Harshana ,

          Just to clarify about your patch is this for 1.6 branch ? We don't commit or not use SVN tags for developments. 1.6 branch is an active development branch so better to test it on 1.6 branch too.

          Harshana Eranga Martin added a comment -

          Hi,

          Yes. Axis2 codegen 1.6.1 plugin is still broken and this AXIS2-5145_1.6.1_only.patch solves the issue.

          However Axis2 codegen trunk version (1.7.0-SNAPSHOT) is working fine. Hence the above patch should NOT be applied to trunk. It is only applicable to 1.6.1 tag.

          Thanks and Regards,
          Harshana

          Caris Julien added a comment -

          Hi,

          I tested the patch you provided, it works fine for the Service Archive plugin. But I still have the issue with the Code Generator issue.

          Thanks and Regards,
          Julien

          Harshana Eranga Martin added a comment -

          Hi All,

          Currently there is a set of unwanted import-packages are added to the axis2-eclipse-service plugin. Eclipse plugin fails to start due to these unsatisfied imports.

          Below is an example:

          org.osgi.framework.BundleException: The bundle "org.apache.axis2.eclipse.service.plugin_1.7.0.SNAPSHOT [763]" could not be resolved. Reason: Missing Constraint: Import-Package: com.sun.codemodel; version="0.0.0"
          at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1327)
          at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1311)
          at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:323)
          at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:299)
          at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:291)
          at org.eclipse.osgi.framework.internal.core.FrameworkCommandProvider._start(FrameworkCommandProvider.java:333)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:597)
          at org.eclipse.osgi.framework.internal.core.FrameworkCommandInterpreter.execute(FrameworkCommandInterpreter.java:209)
          at org.eclipse.osgi.framework.internal.core.FrameworkConsole.docommand(FrameworkConsole.java:155)
          at org.eclipse.osgi.framework.internal.core.FrameworkConsole.runConsole(FrameworkConsole.java:140)
          at org.eclipse.osgi.framework.internal.core.FrameworkConsole.run(FrameworkConsole.java:104)
          at java.lang.Thread.run(Thread.java:662)

          And the Manifest contains:

          Import-Package: com.sun.codemodel,com.sun.codemodel.writer,com.sun.ist
          ack,com.sun.istack.tools,com.sun.mirror.apt,com.sun.mirror.declaratio
          n,com.sun.mirror.type,com.sun.mirror.util,com.sun.tools.apt,com.sun.t
          ools.xjc,com.sun.tools.xjc.api,com.sun.tools.xjc.api.util,com.sun.too ...

          Hence I have excluded these Import-Packages from the manifest by fixing the maven-bundle-plugin rules.

          I have attached the patch here. I have tested the fixed plugins with both Eclipse Helios and Indigo JavaEE distributions.

          Please verify and apply the patch.

          Thanks and Regards,
          Harshana

          Harshana Eranga Martin added a comment -

          Hi,

          I managed to reproduce the issue. This is due to a missing dependency in the plugin. Will provide a patch to fix this.

          Thanks and Regards,
          Harshana

          Ashutosh Jadhav added a comment -

          Hi,

          I am facing the same issue in Eclipse Indigo Java EE distribution on OS X lion. In fact same issue exists for Service Archive plugin as well.

          Harshana Eranga Martin added a comment -

          What is the Eclipse distribution you are using? Is it Eclipse Indigo Java EE distribution? If not, you need to use it.


            People

            • Assignee:
              Andreas Veithen
              Reporter:
              Mohamed Saleem
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development