Axis2
  1. Axis2
  2. AXIS2-4896

Unable to install axis2.eclipse.codegen.plugin into eclipse

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.5.2, 1.5.3
    • Fix Version/s: 1.5.4, 1.6.0
    • Component/s: ide plugins
    • Labels:
      None
    • Environment:
      Eclipse : Version: Helios Service Release 1
      Build id: 20100917-0705, OS: Windows; axis2-eclipse-codegen-plugin-1.5.3

      Description

      I extracted the plug in zip and put the same into the plugins directory of
      Eclipse and restarted the eclipse. but the plugin was not getting instatlled.

      The version of the plugin was axis2.eclipse.codegen.plugin-1.5.3.

      doesn't eclipse automatically add the plugin after it has been put in the
      eclipse/plugins

      Please throw some light

      Following are all the possibilities I pursued and in each case restarted the
      eclipse:

      • I extracted the axis2-eclipse-codegen-plugin-1.5.3 jar and put the same in
        the plugins folder.
      • I repeated the above step and put the same in the dropins folder.
      • I tried just dropping the jar in the plugins and the dropin folder
      • I went to help->Install new software->Add repository and tried adding the jar
        in the archive but it says it is not a relevant update site. There is no place
        other than that in the Install new software UI I could browse to the folder ot
        the location of the jar.
        *I Installed the axis2 tools again from the Web tools platform 3.2.0 in the all
        available sites from the Install new software UI.
      • I tried all the above things from two different eclipse installations
        Version: Helios Service Release 1
        Build id: 20100917-0705
        and also on other machines

      I am a newbiw to axis2 and I need those code gen plugin to be working so that
      it makes my task a little easy. Please treat this matter as of urgent
      importance. I am stuck with not able to install the pluin for the past two
      days.

      & also to add the directory structure when i put the plugin in the plugins
      folder is

      eclipse-jee-helios-SR1-win32\eclipse\plugins\org.apache.axis2.eclipse.codegen.plugin_1.5.3
      ->icons
      ->lib
      ->META_INF
      ->org
      ->help_toc
      ->LICENSE
      ->NOTICE
      ->plugin

      & also to add there was no specific info on the error log view in eclipse

      I testes both 1.5.3 and 1.5.2
      --------------------------------------------------------------------------------

        Issue Links

          Activity

          Andreas Veithen added a comment -

          Yes, the second issue was handled by AXIS2-4901 and a fix is contained in the 1.5.4 release as well.

          Harshana Eranga Martin added a comment -

          Hi All,

          Has any one reported this new issue in JIRA? There is no such bug reported under ide_plugins category. I'm asking this because, I checked out the truck source code and when I run it the plugin in self contained manner in Eclipse, I am able to run the plugin without any issue as indicated above. Therefore if any one still getting the error described in the above comments , please open a new Jira entry and include the stack traces, error logs and steps to reproduce the error.

          Thanks and Regards,
          Harshana

          Andreas Veithen added a comment -

          Although from the user's perspective it has the same consequence (i.e. that it renders the plugin unusable), from a technical point of view it is a different issue. Therefore you should open a different JIRA report for it.

          raghutpk added a comment -

          In addition this is the error log which throws up

          Message:
          Problems occurred when invoking code from plug-in: "org.eclipse.jface".

          Exception Stack Trace:
          java.lang.LinkageError: loader constraint violation in interface itable initialization: when resolving method "org.apache.xerces.dom.CoreDocumentImpl.getDomConfig()Lorg/w3c/dom/DOMConfiguration;" the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) of the current class, org/apache/xerces/dom/CoreDocumentImpl, and the class loader (instance of <bootloader>) for interface org/w3c/dom/Document have different Class objects for the type org/w3c/dom/DOMConfiguration used in the signature
          at org.apache.xerces.parsers.AbstractDOMParser.startDocument(Unknown Source)
          at org.apache.xerces.impl.dtd.XMLDTDValidator.startDocument(Unknown Source)
          at org.apache.xerces.impl.XMLDocumentScannerImpl.startEntity(Unknown Source)
          at org.apache.xerces.impl.XMLVersionDetector.startDocumentParsing(Unknown Source)
          at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
          at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
          at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
          at org.apache.xerces.parsers.DOMParser.parse(Unknown Source)
          at org.apache.xerces.jaxp.DocumentBuilderImpl.parse(Unknown Source)
          at com.ibm.wsdl.xml.WSDLReaderImpl.getDocument(Unknown Source)
          at com.ibm.wsdl.xml.WSDLReaderImpl.readWSDL(Unknown Source)
          at com.ibm.wsdl.xml.WSDLReaderImpl.readWSDL(Unknown Source)
          at org.apache.axis2.tool.codegen.eclipse.util.WSDLPropertyReader.readWSDL(WSDLPropertyReader.java:53)
          at org.apache.axis2.tool.codegen.eclipse.ui.OptionsPage.populateParamsFromWSDL(OptionsPage.java:759)

          raghutpk added a comment -

          Thanks a lot for resolving the issue for installing the plugin.

          But after you restart the eclipse then and click on the Axis2 Code Generator in the Axis2Wizards This log props out

          An error has occurred. See error log for more details.
          loader constraint violation in interface itable initialization: when resolving method "org.apache.xerces.dom.CoreDocumentImpl.getDomConfig()Lorg/w3c/dom/DOMConfiguration;" the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) of the current class, org/apache/xerces/dom/CoreDocumentImpl, and the class loader (instance of <bootloader>) for interface org/w3c/dom/Document have different Class objects for the type org/w3c/dom/DOMConfiguration used in the signature

          Isn't the issue related to the earlier issue, that is the reason I re opened the issue. Virtually the plugin is of no use again.

          Andreas Veithen added a comment -

          Updated the installation instructions in the trunk and on the 1.5 branch. They will be republished during the 1.5.4 or 1.6 release.

          Andreas Veithen added a comment -

          @isola009: Whatever the problem is, it has nothing to do with the issue described in this JIRA report. You need to open a new JIRA report and provide a complete and accurate description (i.e. more than "It doesn't work!"...) of the problem. Note that this is not a discussion forum, but a bug tracking system.

          isola009 added a comment -

          The problem is not the display. Now, the problem is that the next button of "WSDL Selection page" form doesn't work. I can't finish wizard.

          Andreas Veithen added a comment -

          @isola009: I deduce from your comment that you were able to install the plugins. Thus, the present issue is resolved (only the documentation needs to be updated). If there are display problems in the wizard, then this is a different problem and you should open another JIRA issue for that.

          isola009 added a comment -

          If I maximize then I can see de wizard but the next button of "WSDL Selection page" form doesn't work. I can't finish.

          isola009 added a comment -

          The wizzard is empty! I don't see nothing, only the titles (and subtitles).

          Andreas Veithen added a comment -

          I fixed the sun.io issue (see r1039203) and I was able to install the two plugins into Helios by extracting the ZIP files and placing the two plugin JARs directly into the dropins folder (i.e. without the plugins directory).

          The fixed versions of the plugins will be available starting with build #101 (i.e. in a couple of hours) from the following locations:

          https://hudson.apache.org/hudson/job/axis2-1.5/lastBuild/org.apache.axis2$axis2.eclipse.codegen.plugin/
          https://hudson.apache.org/hudson/job/axis2-1.5/lastBuild/org.apache.axis2$axis2.eclipse.service.plugin/

          Andreas Veithen added a comment -

          Here is the analysis of the sun.io issue:

          The reference to the sun.io package is actually introduced by the embedded Xerces dependency, more specifically by the org.apache.xml.serialize.EncodingInfo.CharToByteConverterMethods class [1]. Although Xerces uses reflection to access (or attempt to access) classes in the sun.io package, it appears that the Felix bundle plugin is still able to extract this reference from the following expression in the Xerces code:

          Class.forName("sun.io.CharToByteConverter")

          Since Xerces has no hard dependency on sun.io.CharToByteConverter and uses that class only as a last resort on old JREs, it is safe to exclude sun.io from the list of imported packages.

          It should be noted that the trunk (i.e. Axis2 1.6) doesn't have any dependency on Xerces and works with whatever DOM implementation is provided by the JRE. However, the Woden version used by the 1.5 branch has a hard dependency on some Xerces classes, so that we can't remove this dependency if we want to preserve the WSDL 2.0 support.

          To summarize:

          • The issue doesn't occur with the Eclipse plugins built from the trunk.
          • On the 1.5 branch, the sun.io package needs to be excluded from the Import-Package attribute.

          [1] http://svn.apache.org/repos/asf/xerces/java/tags/Xerces-J_2_8_1/src/org/apache/xml/serialize/EncodingInfo.java

          Shankar added a comment -

          Hi Andreas Veithen,

          Where can I download the latest plugins without the above issue.

          Thanks !!
          Regards,
          Shankar

          isola009 added a comment -

          It doesn't work!

          raghutpk added a comment -

          This is the zip of the codegen plugin folder I am putting into the plugin folder of the Eclipse.

          raghutpk added a comment -

          Thank you very much for all the replies. I know now atleast that it is a bug. I removed the sun.io package from the Import-Package attribute from the META-INF/MANIFEST.MF file in the plugin JAR, but it doesn't seem to solve my problem. It doesn't appear in the UI still. Please find attached a zip of the folder I am dropping it into the plugins directory. Is there anything else i need to do?

          Andreas Veithen added a comment -

          This is definitely a bug. I know more or less where this comes from, and it will be fixed in the coming days. If you are in an extreme hurry, then you can try to edit the META-INF/MANIFEST.MF file in the plugin JARs to remove the sun.io package from the Import-Package attribute.

          raghutpk added a comment -

          Thank you very much Andreas .Is that a bug do you think? Could you be a little elaborate and suggest alternatives if possible. That ll help me a lot because of time crunch.

          Thanks
          Raghu

          Andreas Veithen added a comment -

          When I force installation using the OSGI console (eclipse -console), I get the following errors when attempting to start the bundle:

          org.osgi.framework.BundleException: The bundle "org.apache.axis2.eclipse.codegen.plugin_1.5.2 [723]" could not be resolved. Reason: Missing Constraint: Import-Package: sun.io; version="0.0.0"

          org.osgi.framework.BundleException: The bundle "org.apache.axis2.eclipse.service.plugin_1.5.2 [724]" could not be resolved. Reason: Missing Constraint: Import-Package: sun.io; version="0.0.0"

          There should indeed be no import of sun.io.

          raghutpk added a comment -

          Yes I tested both of them .

          Andreas Veithen added a comment -

          By setting the "Affects Version/s" field to "1.5.3, 1.5.2", you are making a statement that you tested that with the 1.5.2 versions of the plugins as well. Can you confirm that?


            People

            • Assignee:
              Andreas Veithen
              Reporter:
              raghutpk
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 48h
                48h
                Remaining:
                Remaining Estimate - 48h
                48h
                Logged:
                Time Spent - Not Specified
                Not Specified

                  Development