Axis2
  1. Axis2
  2. AXIS2-4464

Axis2 1.5 not compatible with Eclipse JST Web Services

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: 1.5
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      As pointed out by Alexander Bruch, Axis2 1.5 doesn't work well together with the Web Service tooling in Eclipse JST. There is an open issue [1] for this in the JST bug tracker, but if we can implement some workarounds to make it work with the current version of JST, we should do so.

      Steps to reproduce:

      0. Open Eclipse
      1. Configure Axis2

      • Goto Menu Windows -> Preferences -> Web Services -> Axis2 Preferences
      • Choose the Axis2 installation Path i.e. on Windows c:\Program Files\axis2-1.5
      • Apply
        3. Create new Dynamic WbProject
      • Goto Menu File -> New -> Dynamic Web Project
      • Project name: TestAxis2-1.5
      • Target Runtime i.e. "Apache Tomcat 6.0"
      • Dynamic Web module version: 2.5
      • Configuration: Default Configuration for Apache Tomcat v6.0
      • Configuration: Click Button "Modify"
      • Activate Root Checkbox of Axis2 Webservices
        (This should install axis2 Project Facets (axis2-web, libs etc.)
      • Click Next / Finish until the Project setup is completed

      4. Create POJO

      • Create New Java Class : Package com.test.axis2, Class Name SimplePOJO
      • Add two Private properties (String name, int age) and let eclipse generate public getters and setters.
      • Save The niew Class

      5. Create WebService

      • Right click on the new SimplePOJO.java
      • chosse WebService -> Create WebService
      • At the configuration Section choose:
        Server: Tomcat v6.0 Server
        Webservice runtime: Apache Axis2
        Service projectz: TestAxis1.5

      Move the Slider to the top -> "Test Service"
      Move the Client Slider to the bottom -> "No client"

      • click Next
      • In the next Dialog select " Generate a default service.xml file
      • Click Next
      • In the Next Dialog select "Start Server" if not already startes
      • Click next / finish

      Issue no. 1: The generated web.xml refers to org.apache.axis2.transport.http.AxisAdminServlet, but this class has been moved to org.apache.axis2.webapp.

      [1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=282466

        Issue Links

          Activity

          No work has yet been logged on this issue.

            People

            • Assignee:
              Andreas Veithen
              Reporter:
              Andreas Veithen
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:

                Development