Axis2
  1. Axis2
  2. AXIS2-4437

Possible wsdl mixed-up while have load form differend clients

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.5
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      axis2j 1.5 running in tomcat 6.0 on Linux (debian testing)
      Services are created using POJO.

      Description

      Description of our test environment:

      We have two services in the webserver (tomcat/axis2j), one gives the axis version, and another calculates two numbers and returns the result. This means that both services results in two different wsdl's.

      Now we have a client that gets the wsdl (libcurl) and tries to find the operation expected to be in the wsdl.

      GetVersion?wsdl has operation "show_version"
      TestService?wsdl has operation "calc_numbers"

      Description of the problem:

      Now we start calling two clients at ones (parallel) xxx times. Each client knows about which operation belongs to a particular web services.

      Now we think that the web server is sometimes sending the wrong wsdl back to a particular client. Client one needs to find operation "show_version" in "GetVersion?wsdl", but sometimes it tries to search in wsdl "TestService?wsdl".

      To exclude problems on our side, we set-up another machine with the same webservices and call only web-services A from machine A and web-services B from machine B. Now we have no problem.

        Issue Links

          Activity

          Chris Bontempi added a comment -

          We are also seeing this issue. There does not seem to be a pattern to it, and it is infrequent (maybe every 1000th call or so?). We have C code that requests the WSDL before it makes a service call, and on occasion that call to xxx?wsdl returns the WSDL for the wrong service. So far it is always the same pair of services – always the same WSDL being requested and always the same wrong WSDL being returned, but that could just be a quirk of how our particular application works.

          Andreas Veithen added a comment -

          Chris,

          What is the Axis2 and Axiom version you are using? Do you use Woodstox or the StAX implementation in the JRE?

          Andreas Veithen added a comment -

          I thank that AXIS2-4819 correctly identifies the root cause of this issue. Flagging the present issue as duplicate.


            People

            • Assignee:
              Unassigned
              Reporter:
              Meindert Oldenburger
            • Votes:
              1 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development