Uploaded image for project: 'Axis2'
  1. Axis2
  2. AXIS2-4375

Error loading WebappClassLoader when deploy axis2-1.5 with eclipse ganymede and tomcat 6.0.20

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Critical
    • Resolution: Invalid
    • 1.5
    • None
    • deployment
    • None
    • eclipse ganymede 3.4.2, jvm 1.6_13, axis2-1.5, apache tomcat 6.0.20

    Description

      I create a dynamic web project on eclipse
      I add the project facets axis 2
      I deploy on target apache tomcat 6.0.20

      and i've got the error :

      GRAVE: Error loading WebappClassLoader
      delegate: false
      repositories:
      /WEB-INF/classes/
      ----------> Parent Classloader:
      org.apache.catalina.loader.StandardClassLoader@ca2dce
      org.apache.axis2.transport.http.AxisAdminServlet
      java.lang.ClassNotFoundException: org.apache.axis2.transport.http.AxisAdminServlet
      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1387)
      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1233)
      at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1095)
      at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:993)
      at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4149)
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:4458)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
      at org.apache.catalina.core.StandardHost.start(StandardHost.java:722)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
      at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
      at org.apache.catalina.core.StandardService.start(StandardService.java:516)
      at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
      at org.apache.catalina.startup.Catalina.start(Catalina.java:583)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
      at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
      12 juin 2009 20:01:08 org.apache.catalina.core.StandardContext loadOnStartup
      GRAVE: La servlet /webservices-dsi a généré une exception "load()"
      java.lang.ClassNotFoundException: org.apache.axis2.transport.http.AxisAdminServlet
      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1387)
      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1233)
      at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1095)
      at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:993)
      at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4149)
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:4458)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
      at org.apache.catalina.core.StandardHost.start(StandardHost.java:722)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
      at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
      at org.apache.catalina.core.StandardService.start(StandardService.java:516)
      at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
      at org.apache.catalina.startup.Catalina.start(Catalina.java:583)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
      at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)

      THE FOLDER /WEB-INF/classes/ doesn't copied in the build folder. And when i copy it manually it's oK but when i click on the link to see the services i've the error :

      javax.servlet.ServletException: "Servlet.init()" pour la servlet AxisServlet a généré une exception
      org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
      org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
      org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:849)
      org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
      org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:454)
      java.lang.Thread.run(Thread.java:619)

      cause mère

      java.lang.NoClassDefFoundError: org/apache/http/HttpResponseFactory
      org.apache.axis2.transport.http.SimpleHTTPServer.init(SimpleHTTPServer.java:116)
      org.apache.axis2.engine.ListenerManager.init(ListenerManager.java:74)
      org.apache.axis2.transport.http.AxisServlet.init(AxisServlet.java:449)
      org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
      org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
      org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:849)
      org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
      org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:454)
      java.lang.Thread.run(Thread.java:619)

      cause mère

      java.lang.ClassNotFoundException: org.apache.http.HttpResponseFactory
      org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1387)
      org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1233)
      java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
      org.apache.axis2.transport.http.SimpleHTTPServer.init(SimpleHTTPServer.java:116)
      org.apache.axis2.engine.ListenerManager.init(ListenerManager.java:74)
      org.apache.axis2.transport.http.AxisServlet.init(AxisServlet.java:449)
      org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
      org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
      org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:849)
      org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
      org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:454)
      java.lang.Thread.run(Thread.java:619)

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              fpitpit Fab Pit
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: