Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.4, 1.4.1
    • Fix Version/s: 1.5.3, 1.6.0
    • Component/s: kernel
    • Labels:
      None

      Description

      If the invocation of the business logic throws an exception that is mapped to a fault response, the exception is logged as error (AxisEngine.receive(MessageContext msgContext), see end of the method).

      Logging an error usually indicates that something went wrong. From the perspective of the Axis2 framework, however, everything is perfectly OK. The business logic has thrown an exception, it is returned to the invoker as a fault, so where's the error? (Compare in contrast the better handling in AbstractMessageReceiver.receive(final MessageContext messageCtx). Here the exception is only logged as error if it happens to be an "in only" message exchange, i.e. when the client cannot be notified about the exception.)

      We have a system where exceptions are thrown by the business logic quite frequently (it's a "customer not registered for this service" situation). While you could argue that we had better defined a WSDL in which this situation is mapped to some "normal" result instead of a fault, our definition is perfectly within the SOAP specs. The excessive error messages in the log, however, result in unnecessary alerts in monitoring. We'll probably have to set the log level for AxisKernel to FATAL, although we do not like to do this.

        Issue Links

          Activity

          Michael Lipp created issue -
          Torben Riis added a comment -

          I totally agree. AxisFault from business logic should not be logged at error level. Maybe debug but not error level.
          It would be nice if it was possible to mark an AxisFault as a business logic fault...

          /Torben Riis

          Andreas Veithen made changes -
          Field Original Value New Value
          Assignee Andreas Veithen [ veithen ]
          Andreas Veithen made changes -
          Link This issue duplicates AXIS2-4280 [ AXIS2-4280 ]
          Andreas Veithen added a comment -

          Duplicate of AXIS2-4280, which will be fixed in 1.5.3 and 1.6.

          Andreas Veithen made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Fix Version/s 1.6 [ 12313622 ]
          Fix Version/s 1.5.3 [ 12315367 ]
          Resolution Duplicate [ 3 ]

            People

            • Assignee:
              Andreas Veithen
              Reporter:
              Michael Lipp
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development