Uploaded image for project: 'Axis2'
  1. Axis2
  2. AXIS2-4050

client proxy authentication failed, screwed up http headers

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Blocker
    • Resolution: Fixed
    • 1.4
    • 1.6.0
    • transports
    • None
    • Linux debian etch

    Description

      (see also http://markmail.org/message/lvabtbivnwuptfm2)
      trying to connect an Axis2 Client to a Web Service through a proxy with authentication.

      Tried with
      System.setProperty("http....
      and also with
      HttpTransportProperties.ProxyProperties..

      I see those configuration enables proxy, but does screw up the proxy-authentication. Here is the Request HTTP POST

      POST http://xxxxxxxxxxxxxxxxxxxxx HTTP/1.0\r\n
      Request Method: POST
      Request URI: http://xxxxxxxxxxxxxxxxxxxxxxxxx
      Request Version: HTTP/1.0
      Content-Type: text/xml; charset=UTF-8\r\n
      SOAPAction: "http://xxxxxxxxxxxxxxxxx"\r\n
      User-Agent: Axis2\r\n
      Proxy-Connection: Keep-Alive\r\n
      Content-Length: 5098
      Proxy-Authorization: Basic Og==\r\n
      Credentials: :
      Host: xxxxxxxxx:4711\r\n
      \r\n

      Attachments

        Issue Links

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            milinda Milinda Pathirage
            lischke Stefan Lischke
            Votes:
            2 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment