Uploaded image for project: 'Axis2'
  1. Axis2
  2. AXIS2-3698

HTTP ports are not included in the generated wsdl if the service is deployed in a server configured with both http and https transports

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: nightly
    • Fix Version/s: 1.6.0
    • Component/s: wsdl
    • Labels:
      None
    • Environment:
      winxp, jdk15

      Description

      I have a pojo service and which worked fine with previous axis2 builds. I usually generate code by specifying httpsoap11 port name of the generated wsdl (?wsdl). When I tried to generate code using the same httpsoap11 port in the recent Axis2 nightlies, it failed due to the requested port is not available in the wsdl (?wsdl).
      It seems that http ports are not included in the generated wsdl if both http and https transports are configured in the servlet container.

      Steps to reproduce:
      ================
      1. Deploy the attached service in tomcat which is configured with both http and https transports
      2. access http://localhost:8080/axis2 and select the deployed service
      3. Check the generated wsdl

        Attachments

        1. RestService.aar
          2 kB
          Charitha Kankanambe

          Issue Links

            Activity

              People

              • Assignee:
                veithen Andreas Veithen
                Reporter:
                charitha Charitha Kankanambe
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: