Axiom
  1. Axiom
  2. AXIOM-65

OM Serialization doesn't work when a tree contains more than on non-built OMElements

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Consider the following scenario.

      • You programatically create an OMTree, say you call SOAPFactory.createDefaultSOAPEnvelope().
      • You create an OMElement out of an XMLStreamReader and adds that as a child in SOAPHeader
      • You do the same thing and adds another node to SOAPHeader.
      • When you serialize this, only the first child gets serialized, ignoring the second one.

      This seems to be the root cause for http://issues.apache.org/jira/browse/AXIS2-928 as well.

        Issue Links

          Activity

          Eran Chinthaka added a comment -

          Fixed in r443065. Thanks Ruchith and Thilina for the help !!


            People

            • Assignee:
              Eran Chinthaka
              Reporter:
              Eran Chinthaka
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development