Axiom
  1. Axiom
  2. AXIOM-315

Handling of completeness in OMNodes and correct OM Serialization in DOOM impl

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.2.13
    • Component/s: DOOM
    • Labels:
      None

      Description

      The bug fixed in WSCOMMONS-96 and WSCOMMONS-97 should be reflected in DOOM implementation as well. I consider this as a post Axiom 1.1 release issue.

      1. r443065.diff.txt
        30 kB
        Andreas Veithen

        Issue Links

          Activity

          Hudson added a comment -

          Integrated in ws-axiom-trunk #638 (See https://builds.apache.org/job/ws-axiom-trunk/638/)
          AXIOM-315: Fixed known issues with respect to node completeness in DOOM.

          veithen :
          Files :

          • /webservices/commons/trunk/modules/axiom/modules/axiom-dom/src/main/java/org/apache/axiom/om/impl/dom/ChildNode.java
          • /webservices/commons/trunk/modules/axiom/modules/axiom-dom/src/main/java/org/apache/axiom/om/impl/dom/ParentNode.java
          • /webservices/commons/trunk/modules/axiom/modules/axiom-dom/src/test/java/org/apache/axiom/om/impl/dom/OMImplementationTest.java
          • /webservices/commons/trunk/modules/axiom/modules/axiom-testsuite/src/main/java/org/apache/axiom/ts/om/document/TestIsCompleteAfterAddingIncompleteChild.java
          • /webservices/commons/trunk/modules/axiom/modules/axiom-testsuite/src/main/java/org/apache/axiom/ts/om/document/TestSerializeAndConsumeWithIncompleteDescendant.java
          Hudson added a comment -

          Integrated in ws-axiom-trunk #312 (See https://hudson.apache.org/hudson/job/ws-axiom-trunk/312/)
          Added two test cases that provide evidence for AXIOM-315.

          Andreas Veithen added a comment -

          Reopening this one again because I now have two test cases that show a problem in DOOM that may be related to the present issue/task.

          Hudson added a comment -

          Integrated in ws-axiom-trunk #300 (See https://hudson.apache.org/hudson/job/ws-axiom-trunk/300/)
          Added two new test cases for OMContainer#serializeAndConsume. They will be necessary to ensure non regression when implementing AXIOM-24. In addition, they reveal problems in DOOM which may be related to AXIOM-315.

          Andreas Veithen added a comment -

          The testOMSerializationWithTwoNonBuiltOMElements unit test is now executed against DOOM as well and it passes (with a minor correction to the DOOM code); see r1053681. Therefore I think we can consider this issue as fixed.

          Andreas Veithen added a comment -

          For reference, attached the svn diff for the changes related to WSCOMMONS-96 and WSCOMMONS-97.

          Ruchith Udayanga Fernando added a comment -

          Apologies about the delay ... have to look at the original issues to figure out wht needs to be done ... can we please push this a little further or can someone else please pick this up?

          Thanks,
          Ruchith

          Davanum Srinivas added a comment -

          Ruchith,

          What needs to be done here?

          thanks,
          dims


            People

            • Assignee:
              Andreas Veithen
              Reporter:
              Eran Chinthaka
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development