Apache AWF
  1. Apache AWF
  2. AWF-65

Infinite loop if client disconnects

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Labels:
      None

      Description

      Nicholas Whitehead found a bug that makes the server go into an infinite loop. Bug described on ML, third bullet (http://groups.google.com/group/deft-web-server/browse_thread/thread/d59fe5cd35aebfd8)

      Stacktrace:

      22:53:58.876 [I/O-LOOP] ERROR org.deftserver.web.http.HttpResponse - ClosedChannelException during flush(): null
      22:53:58.876 [I/O-LOOP] DEBUG o.d.i.t.JMXDebuggableTimeoutManager - added generic timeout: org.deftserver.io.timeout.Timeout@7162e295
      22:53:58.876 [I/O-LOOP] DEBUG o.d.i.t.JMXDebuggableTimeoutManager - Timeout triggered: org.deftserver.io.timeout.Timeout@7a7c3885

        Activity

        Séven Le Mesle added a comment -

        waiting for review

        Ulrich Stärk added a comment -

        The problem is that we dont act upon end-of-stream (SocketChannel.read(..) returns -1).

        Proposal:

        • We should remove SelectionKey.OP_READ from the interest set for that selection key.
        • If we have sent all data we should close the connection.

          People

          • Assignee:
            Séven Le Mesle
            Reporter:
            Niklas Gustavsson
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development