Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Labels:
      None

      Description

      s/org.deftserver/org.apache.deft (don't forget the test packages)
      I don't think we should do full textual replace (e.g dont change any documentation (eg. NEWS.txt) associated with already released versions. the section for 0.4.0, in NEWS.txt should probably be changed if we refer to the old package structure)

        Activity

        Johnathan Meehan added a comment -

        Provisionally intended to be handled at ~20:00 GMT, Thursday 4th August.

        Johnathan Meehan added a comment -

        Committed:
        http://svn.apache.org/viewvc?rev=1153959&view=rev
        http://svn.apache.org/viewvc?rev=1153965&view=rev

        Formatted code with the Eclipse formatters available here: https://cwiki.apache.org/confluence/display/DEFT/Coding+Standards
        Incomplete, but provide a baseline for future work at least.

        All seems well, but please comment on this task if you notice any problems.

        Roger Schildmeijer added a comment -

        looks good

        Roger Schildmeijer added a comment -

        DeftSystemTest is ignored. Is this correct? If, why?

        Johnathan Meehan added a comment -

        This was done in DEFT-180; I put a comment in the mail I sent at the time that tests creating an instance of the server were sporadically failing. This does not generally break the build, but this particular tests does (causes it to hang). The intention was to look at it these tests at some point; IIRC the problem is intermittent on my own machine.

        Roger Schildmeijer added a comment -

        I see that HttpServerTest.testPortInRange_ok tries to bind a port < 1024 (34). It often requires root access to bind ports < 1024


          People

          • Assignee:
            Johnathan Meehan
            Reporter:
            Roger Schildmeijer
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development