Avro
  1. Avro
  2. AVRO-771

Java: Upgrade dependencies for 1.5.0

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.5.0
    • Component/s: java
    • Labels:
      None

      Description

      This is not a blocker.

      This is the 'mvn versions:display-dependency-updates'

      The following dependencies in Dependency Management are using the newest version:
      [INFO] net.sf.jopt-simple:jopt-simple ................................... 3.2
      [INFO] org.apache.hadoop:hadoop-core ................................. 0.20.2
      [INFO]
      [INFO] The following dependencies in Dependency Management have newer versions:
      [INFO] com.thoughtworks.paranamer:paranamer ................ 2.3 -> 2.3-debug
      [INFO] org.apache.velocity:velocity ...................... 1.6.4 -> 1.7-beta1
      [INFO] org.codehaus.jackson:jackson-mapper-asl ............... 1.4.2 -> 1.7.3
      [INFO] org.jboss.netty:netty ..................... 3.2.1.Final -> 3.2.4.Final
      [INFO] org.mortbay.jetty:jetty ............................. 6.1.22 -> 6.1.26
      [INFO]
      [INFO] The following dependencies in Dependencies have newer versions:
      [INFO] junit:junit ........................................... 4.8.1 -> 4.8.2
      [INFO] org.slf4j:slf4j-api .................................. 1.5.11 -> 1.6.1
      [INFO] org.slf4j:slf4j-simple ............................... 1.5.11 -> 1.6.1

      We should consider a newer Jackson version, at least the latest 1.4.x, but perhaps higher.
      Junit is a trivial upgrade.
      slf4j has some changes affecting compatibility (but is API compatible) in 1.6.x. We may want to delay that one.
      Jetty and Netty can be upgraded.

      The most important one above is Jackson since it is the most likely to have classpath collisions. Even though we do not use features from newer versions, it might be wise to move to that.

      For plugins, there are these updates:
      [INFO] The following plugin updates are available:
      [INFO] maven-surefire-plugin ................................ 2.7.1 -> 2.7.2
      [INFO] org.codehaus.mojo:exec-maven-plugin ...................... 1.1 -> 1.2

      Both of which seem minor by their release notes.

      (see mvn versions:help for more useful tools)

      1. AVRO-771.v2.patch
        2 kB
        Scott Carey
      2. AVRO-771.patch
        2 kB
        Scott Carey

        Activity

        Scott Carey created issue -
        Scott Carey made changes -
        Field Original Value New Value
        Fix Version/s 1.5.0 [ 12315282 ]
        Description
        This is not a blocker.

        This is the 'mvn versions:display-dependency-updates'

        The following dependencies in Dependency Management are using the newest version:
        [INFO] net.sf.jopt-simple:jopt-simple ................................... 3.2
        [INFO] org.apache.hadoop:hadoop-core ................................. 0.20.2
        [INFO]
        [INFO] The following dependencies in Dependency Management have newer versions:
        [INFO] com.thoughtworks.paranamer:paranamer ................ 2.3 -> 2.3-debug
        [INFO] org.apache.velocity:velocity ...................... 1.6.4 -> 1.7-beta1
        [INFO] org.codehaus.jackson:jackson-mapper-asl ............... 1.4.2 -> 1.7.3
        [INFO] org.jboss.netty:netty ..................... 3.2.1.Final -> 3.2.4.Final
        [INFO] org.mortbay.jetty:jetty ............................. 6.1.22 -> 6.1.26
        [INFO]
        [INFO] The following dependencies in Dependencies have newer versions:
        [INFO] junit:junit ........................................... 4.8.1 -> 4.8.2
        [INFO] org.slf4j:slf4j-api .................................. 1.5.11 -> 1.6.1
        [INFO] org.slf4j:slf4j-simple ............................... 1.5.11 -> 1.6.1


        We should consider a newer Jackson version, at least the latest 1.4.x, but perhaps higher.
        Junit is a trivial upgrade.
        slf4j has some changes affecting compatibility (but is API compatible) in 1.6.x. We may want to delay that one.
        Jetty and Netty can be upgraded.

        The most important one above is Jackson since it is the most likely to have classpath collisions. Even though we do not use features from newer versions, it might be wise to move to that.

        For plugins, there are these updates:
        [INFO] The following plugin updates are available:
        [INFO] maven-surefire-plugin ................................ 2.7.1 -> 2.7.2
        [INFO] org.codehaus.mojo:exec-maven-plugin ...................... 1.1 -> 1.2

        Both of which seem minor by their release notes.


        (see mvn versions:help for more useful tools)
        This is not a blocker.

        This is the 'mvn versions:display-dependency-updates'

        The following dependencies in Dependency Management are using the newest version:
        [INFO] net.sf.jopt-simple:jopt-simple ................................... 3.2
        [INFO] org.apache.hadoop:hadoop-core ................................. 0.20.2
        [INFO]
        [INFO] The following dependencies in Dependency Management have newer versions:
        [INFO] com.thoughtworks.paranamer:paranamer ................ 2.3 -> 2.3-debug
        [INFO] org.apache.velocity:velocity ...................... 1.6.4 -> 1.7-beta1
        [INFO] org.codehaus.jackson:jackson-mapper-asl ............... 1.4.2 -> 1.7.3
        [INFO] org.jboss.netty:netty ..................... 3.2.1.Final -> 3.2.4.Final
        [INFO] org.mortbay.jetty:jetty ............................. 6.1.22 -> 6.1.26
        [INFO]
        [INFO] The following dependencies in Dependencies have newer versions:
        [INFO] junit:junit ........................................... 4.8.1 -> 4.8.2
        [INFO] org.slf4j:slf4j-api .................................. 1.5.11 -> 1.6.1
        [INFO] org.slf4j:slf4j-simple ............................... 1.5.11 -> 1.6.1


        We should consider a newer Jackson version, at least the latest 1.4.x, but perhaps higher.
        Junit is a trivial upgrade.
        slf4j has some changes affecting compatibility (but is API compatible) in 1.6.x. We may want to delay that one.
        Jetty and Netty can be upgraded.

        The most important one above is Jackson since it is the most likely to have classpath collisions. Even though we do not use features from newer versions, it might be wise to move to that.

        For plugins, there are these updates:
        [INFO] The following plugin updates are available:
        [INFO] maven-surefire-plugin ................................ 2.7.1 -> 2.7.2
        [INFO] org.codehaus.mojo:exec-maven-plugin ...................... 1.1 -> 1.2

        Both of which seem minor by their release notes.


        (see mvn versions:help for more useful tools)
        Scott Carey made changes -
        Assignee Scott Carey [ scott_carey ]
        Scott Carey added a comment -

        Patch upgrades the following dependencies:

        Jackson to 1.7.3, Jetty to 6.1.22, Netty to 3.2.4.Final, JUnit to 4.8.2.

        It also upgrades two plugins, maven-surefire to 2.7.2 and exec-maven-plugin to 1.2.

        Scott Carey made changes -
        Attachment AVRO-771.patch [ 12471508 ]
        Scott Carey added a comment - - edited

        Upgraded dependencies. All upgrades were minor except for Jackson, which went from 1.4.2 to 1.7.3.

        All tests pass, top-level test passes.

        Top-level 'dist' fails in unrelated issue due to RAT on file:
        lang/c/src/avro-c.pc.in

        Scott Carey made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Holger Hoffstätte added a comment -

        Great to see these updates, but one question. Why do you want to keep using slf 1.5 which has some pretty nasty bugs? IIRC the "binary incompatibility" was between the various slf modules themselves and only in rare cases involved user code. Using 1.6 will make integration with other packages & applications a lot easier and future-proof, see: http://slf4j.org/manual.html#libraries

        Scott Carey added a comment -

        We've already had one user with an error caused by 1.5.11 on the same classpath as 1.6.x. If we upgrade to 1.6.x, we'll fix those already using 1.6.x and break others. But I suppose that works both ways. http://www.slf4j.org/faq.html#compatibility
        Doing some digging around it looks like many projects have upgraded already, but others have not. If 1.5.x lasts a while, it should probably be on slf4j 1.6.x.

        I'll attach a patch with that change in there too.

        Scott Carey made changes -
        Attachment AVRO-771.v2.patch [ 12471531 ]
        Doug Cutting added a comment -

        This is a good time to update and everything works for me with these updated versions. +1

        Scott Carey added a comment -

        Committed @ r1073141

        Scott Carey made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Doug Cutting made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Doug Cutting made changes -
        Component/s java [ 12312780 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Patch Available Patch Available
        43m 52s 1 Scott Carey 20/Feb/11 11:20
        Patch Available Patch Available Resolved Resolved
        1d 10h 1m 1 Scott Carey 21/Feb/11 21:21
        Resolved Resolved Closed Closed
        18d 3h 11m 1 Doug Cutting 12/Mar/11 00:32

          People

          • Assignee:
            Scott Carey
            Reporter:
            Scott Carey
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development