Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.0.0
    • Component/s: None
    • Labels:
      None
    1. 73_v1.patch
      0.4 kB
      Sharad Agarwal

      Activity

      Matt Massie added a comment -

      Reported by Matei Zaharia and Tom White...

      For me, the Python tests are failing using Python 2.5.1 on Mac OS X. The
      error is as follows:

      testipcreflect.py
      Modules: 'testio','testio','testioreflect','testipc','testipcreflect'
      Non-null modules arg. creating script
      pythonpath:
      /Users/matei/workspace/avro-1.0.0-rc1/src/py:/Users/matei/workspace/avro-1.0.0-rc1/src/test/py:/Users/matei/workspace/avro-1.0.0-rc1/lib/py
      [py-test] Traceback (most recent call last):
      [py-test] File "<stdin>", line 2, in <module>
      [py-test] File
      "/System/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/unittest.py",
      line 767, in _init_
      [py-test] self.parseArgs(argv)
      [py-test] File
      "/System/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/unittest.py",
      line 794, in parseArgs
      [py-test] self.createTests()
      [py-test] File
      "/System/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/unittest.py",
      line 800, in createTests
      [py-test] self.module)
      [py-test] File
      "/System/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/unittest.py",
      line 565, in loadTestsFromNames
      [py-test] suites = [self.loadTestsFromName(name, module) for name in
      names]
      [py-test] File
      "/System/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/unittest.py",
      line 533, in loadTestsFromName
      [py-test] module = _import_('.'.join(parts_copy))
      [py-test] File
      "/Users/matei/workspace/avro-1.0.0-rc1/src/test/py/testipc.py", line 19, in
      <module>
      [py-test] import avro.ipc as ipc
      [py-test] File
      "/Users/matei/workspace/avro-1.0.0-rc1/src/py/avro/ipc.py", line 63, in
      <module>
      [py-test] "HandshakeRequest.avsc").read())
      [py-test] File
      "/Users/matei/workspace/avro-1.0.0-rc1/src/py/avro/schema.py", line 521, in
      parse
      [py-test] return _parse(dict, _Names())
      [py-test] File
      "/Users/matei/workspace/avro-1.0.0-rc1/src/py/avro/schema.py", line 483, in
      _parse
      [py-test] fields[fieldname] = Field(fieldname, _parse(fieldtype,
      names),
      [py-test] File
      "/Users/matei/workspace/avro-1.0.0-rc1/src/py/avro/schema.py", line 509, in
      _parse
      [py-test] elemtypes.append(_parse(elemtype, names))
      [py-test] File
      "/Users/matei/workspace/avro-1.0.0-rc1/src/py/avro/schema.py", line 512, in
      _parse
      [py-test] raise SchemaParseException("Schema not yet supported:" +
      obj._str_())
      [py-test] avro.schema.SchemaParseException: Schema not yet supported:null

      Doug Cutting added a comment -

      Should this be a 1.0.0 blocker? Do we think this is related to OS X or Python 2.5.1? I use Linux and Python 2.6.2 and do not see this, and our README.txt says things should work with Python 2.5 or greater.

      Sharad Agarwal added a comment -

      I run linux and tests run on fine it. I got hold of Mac OS X 10.5.7 to test this. I could not reproduce this. However I got same error as reported in Avro-64.

      Sharad Agarwal added a comment -

      In my last comment, I used python 2.5.1 on Mac.
      Matei, Tom - Which version of mac OS you are seeing this problem on?

      Sharad Agarwal added a comment -

      The problem appears to be with simplejson parser on some platforms. http://code.google.com/p/simplejson/issues/detail?id=40
      Tom/Matei, can you try applying this patch, if it fixes the problem? I can't reproduce so can't test.

      Tom White added a comment -

      This patch fixes the problem for me (Mac OS X 10.5.6, Python 2.5.1). Just hitting AVRO-64 now.

      Thanks Sharad.

      Sharad Agarwal added a comment -

      I committed this. Thanks Tom and Matei for testing.


        People

        • Assignee:
          Sharad Agarwal
          Reporter:
          Matt Massie
        • Votes:
          0 Vote for this issue
          Watchers:
          1 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development