Avro
  1. Avro
  2. AVRO-276

TestGenAvro fails because of charset inconsistencies

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.3.0
    • Component/s: java
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      On the Mac, I get a failure with TestGenAvro. I traced it down to not explicitly setting the string encoding when reading the expected input. Patch to follow shortly.

      1. AVRO-276.patch.txt
        2 kB
        Philip Zeyliger

        Activity

        Hide
        Philip Zeyliger added a comment -

        This is essentially a one-liner, replacing FileReader(...) with InputStreamReader(InputStream(..., utf-8)). I'd also like to sneak in a change to AllTests.launch, which allows this test to run in Eclipse (it introduced a dependency on a new System variable).

        Show
        Philip Zeyliger added a comment - This is essentially a one-liner, replacing FileReader(...) with InputStreamReader(InputStream(..., utf-8)). I'd also like to sneak in a change to AllTests.launch, which allows this test to run in Eclipse (it introduced a dependency on a new System variable).
        Hide
        Doug Cutting added a comment -

        I just committed this. Thanks, Philip.

        Show
        Doug Cutting added a comment - I just committed this. Thanks, Philip.

          People

          • Assignee:
            Philip Zeyliger
            Reporter:
            Philip Zeyliger
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development