Avro
  1. Avro
  2. AVRO-1553

MapReduce never uses MapOutputValueSchema

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.7.7
    • Fix Version/s: 1.7.8
    • Component/s: java
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      The OutputValueSchema is always used.

      1. AVRO-1553.patch
        5 kB
        Tom White
      2. AVRO-1553.patch
        1 kB
        Tom White

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Patch Available Patch Available
        1h 59m 1 Tom White 28/Jul/14 17:58
        Patch Available Patch Available Resolved Resolved
        19h 51m 1 Tom White 29/Jul/14 13:50
        Hudson added a comment -

        SUCCESS: Integrated in AvroJava #470 (See https://builds.apache.org/job/AvroJava/470/)
        AVRO-1553. Java: MapReduce never uses MapOutputValueSchema. (tomwhite: rev 1614329)

        • /avro/trunk/CHANGES.txt
        • /avro/trunk/lang/java/mapred/src/main/java/org/apache/avro/hadoop/io/AvroDatumConverterFactory.java
        • /avro/trunk/lang/java/mapred/src/test/java/org/apache/avro/mapreduce/TestKeyValueInput.java
        Tom White made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Hadoop Flags Reviewed [ 10343 ]
        Resolution Fixed [ 1 ]
        Tom White added a comment -

        I committed this.

        ASF subversion and git services added a comment -

        Commit 1614329 from tomwhite@apache.org in branch 'avro/trunk'
        [ https://svn.apache.org/r1614329 ]

        AVRO-1553. Java: MapReduce never uses MapOutputValueSchema.

        Doug Cutting added a comment -

        Patch looks good. Test fails without patch, succeeds with. +1

        Doug Cutting made changes -
        Comment [ Patch looks good. Should we add a test? ]
        Tom White added a comment -

        No sooner said than done.

        Tom White made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Fix Version/s 1.7.8 [ 12327467 ]
        Tom White made changes -
        Attachment AVRO-1553.patch [ 12658172 ]
        Tom White added a comment -

        Added a test that fails without the fix.

        Tom White made changes -
        Field Original Value New Value
        Attachment AVRO-1553.patch [ 12658142 ]
        Tom White added a comment -

        This is caused by a missing assignment in AvroDatumConverterFactory (introduced in AVRO-1356).

        Tom White created issue -

          People

          • Assignee:
            Tom White
            Reporter:
            Tom White
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development